What does the colon followed by number in ArcPro model builder mean?

191
1
Jump to solution
05-15-2019 04:17 AM
DuncanHornby
MVP Frequent Contributor

I'm hoping someone from ESRI could explain the following as I could find no mention of it in the online help.

In ArcPro whilst building a model some parameters start to mysteriously be numbered. It is not clear why or what their significance is and which one to choose.

If anyone can explain this I would then suggest ESRI add this to the documentation.

1 Solution

Accepted Solutions
KellyKoenig
New Contributor III

When you're using a geoprocessing tool and have two layers with the same name in your map, it will assign a numbered suffix to each in order to differentiate the two in your list of input features. In the example below, the two layers named "Test" in the contents pane are listed as "Test:1" and "Test:2" in the input features drop-down list within the geoprocessing pane.

Two layers sharing the same name of "Test" are shown as "Test:1" and "Test:2" in the geoprocessing input dropdown.

Your model could have a similar naming issue. You can see a list of all your model elements by clicking "Report" on the "ModelBuilder" ribbon while you're editing the model. Hopefully that list will help you narrow down what part of the process is causing the duplicate names so you can edit the name of one and eliminate the numbered suffixes from appearing.

View solution in original post

1 Reply
KellyKoenig
New Contributor III

When you're using a geoprocessing tool and have two layers with the same name in your map, it will assign a numbered suffix to each in order to differentiate the two in your list of input features. In the example below, the two layers named "Test" in the contents pane are listed as "Test:1" and "Test:2" in the input features drop-down list within the geoprocessing pane.

Two layers sharing the same name of "Test" are shown as "Test:1" and "Test:2" in the geoprocessing input dropdown.

Your model could have a similar naming issue. You can see a list of all your model elements by clicking "Report" on the "ModelBuilder" ribbon while you're editing the model. Hopefully that list will help you narrow down what part of the process is causing the duplicate names so you can edit the name of one and eliminate the numbered suffixes from appearing.

View solution in original post