Unable to add Branch Versioning to FeatureDataset

460
3
Jump to solution
12-05-2018 04:08 AM
New Contributor II

Hey Everyone,

I'am trying to register a feature dataset with branch versioning but I am constantly getting the error message

 ERROR 999999: Something unexpected caused the tool to fail. Please refer to the error help for potential solutions, or contact Esri Technical Support http://esriurl.com/support.
 Invalid Multibranch registration  [UTARC.StructureJunction_1]
 Failed to execute (RegisterAsVersioned).

When i delete the feature class StructureJunction_1 from the feature dataset, I get the same error message for another feature class. If I delete that also, I get the error message for the next feature class in the feature dataset and so on.

I am using ArcGIS Pro 2.2.4. The database is an oracle database and my SDE connection file is created with branch versioning enabled.

Can anybody give me a hint what I am doing wrong?

Reply
0 Kudos
1 Solution

Accepted Solutions
Esri Frequent Contributor

Have you followed the workflow for enabling branch versioning? Are there any errors during this process?

Register data as versioned—Geodatabases | ArcGIS Desktop 

Geodatabase

--- George T.

View solution in original post

3 Replies
Esri Frequent Contributor

Have you followed the workflow for enabling branch versioning? Are there any errors during this process?

Register data as versioned—Geodatabases | ArcGIS Desktop 

Geodatabase

--- George T.

View solution in original post

New Contributor II

Thanks for your answer.

We are using Oracle Spatial and not ST_GEOMETRY. We willl change the geometry type of the database.

Is there any plan to support Oracle Spatial in the feature?

Am I correct that in postgres I could use both ST_GEOMETRY and the PostGIS geometry type?

Reply
0 Kudos
Esri Frequent Contributor

I would say yes for Postgres, you can use either spatial type.

--- George T.
Reply
0 Kudos