The Domains for this workspace are read-only.

3522
14
03-12-2019 09:51 AM
deleted-user-IHdgY8AJ1G5z
New Contributor II

Hello, 

I am trying to create some domains in my feature service but I keep getting this message " The Domains for this workspace are read-only" I am not sure what I am supposed to do here. Can anybody help with this? 

I added a sreenshot of my workspace. 

Thanks in advance!

G

0 Kudos
14 Replies
Kyle_LocGov
New Contributor II

Fred, 

Pretty busy here until Monday but I believe I was able to edit the domains in AGOL in the layer page. Might try that. 

 

0 Kudos
GregoryJaredM
New Contributor
That’s the only workflow I’ve found unfortunately
0 Kudos
Kyle_LocGov
New Contributor II

Fred,

You can edit domains in the item details page on AGOL. Is that going to help you? 

0 Kudos
Kyle_LocGov
New Contributor II

https://community.esri.com/t5/arcgis-pro-ideas/change-domain-in-arcgis-online-via-arcgis-pro/idi-p/9...

This is an older thread about a solution that I haven't had the gumption to investigate. If I do, or anyone else does, it might be helpful to post it here. For now, the best method I've found to edit feature service domains is online in the feature overview page.   

 

 

https://community.esri.com/t5/arcgis-pro-ideas/change-domain-in-arcgis-online-via-arcgis-pro/idi-p/9...

OliviaHarrison
New Contributor II

I also have this problem. I need to edit a core layer hosted online using ArcGIS Pro. But there's no way I can export to gdb, edit,then reupload - just way too many dependencies etc. I'm pretty sure I used to be able to change the split policy for domains in Pro, and now can't, which is just frustrating. 

0 Kudos