symbology - not showing everything on map

486
9
Jump to solution
08-26-2021 12:08 PM
KarenHoelscher
New Contributor III

Symbology not all showing on map. see attachment.

Tags (2)
0 Kudos
2 Solutions

Accepted Solutions
JayantaPoddar
MVP Esteemed Contributor

Hello Karen,

Thank you sharing the sample.

Whenever we have overlapping feature parts, the symbology of the feature part created later (highest ObjectID) will be visible. That resulted in the typical symbology issue you just faced.

A solid color symbology of HBP didn't allow you to see the symbology of INT OWND (which actually existed). On the other hand, the hashed symbology of the INT OWND (on top) still allowed you to see the symbols of HBP beneath them.

 

So, I have two workarounds.

Workaround-1 (Preferred):

Define a non-solid symbology for HBP as well (see screenshot below).

JayantaPoddar_0-1630078894125.png

 

 

Workaround-2 (Less Preferred):

If you want to keep the HBP symbology as solid color, then you need to sort the layer based on the Status field in ascending order.

This will put the INT OWND values on top. So, you will be able to see both the values.

* Note: This tool will change the order of the records (Feature parts) in the shapefile. That's why I mentioned it as a less preferred method.

JayantaPoddar_1-1630078894139.png

 

 

 



Think Location

View solution in original post

KenBuja
MVP Honored Contributor

If you have to use solid colors, you could also look at the layer blending capabilities: https://pro.arcgis.com/en/pro-app/latest/help/mapping/layer-properties/apply-visual-effects.htm

We have a layer that has many overlapping features and by using the "Multiply" darkening mode, we can still see all the individual features.

KenBuja_0-1630086709594.png

 

 

View solution in original post

9 Replies
rzufelt
New Contributor

I have seen this with invalid geometry somewhere in your feature class(s).

Could make a copy, run the Repair Geometry tool Repair Geometry Tool on them and see if it fixes the issue.

0 Kudos
KarenHoelscher
New Contributor III

created a copy of the layer and ran the repair geometry tool and created the same symbology. Still doing the same thing. 

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

On clicking "Full Extent", do you see the same Map extent (as the screenshot)?

If yes, could you check if there are redundant overlapping polygons? You could use Find Identical tool. Select field "Shape".



Think Location
0 Kudos
KarenHoelscher
New Contributor III

These are minerals we have leased so all but one have an overlapping polygon (the lease). I create the symbology to put the Mineral Deed on top (orange hash) so you could see the lease give (blue solid) underneath. But you only see a few of the Deeds. 

I did zoom out and it still shows only the few deeds as when zoomed in. I can create a separate layer just for the Deeds but was hoping not having to do that each time.

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

If possible, could you share a sample shapefile (joypoddar.87@gmail.com)?

Also mention the field you are using to symbolize the features.



Think Location
0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Hello Karen,

Thank you sharing the sample.

Whenever we have overlapping feature parts, the symbology of the feature part created later (highest ObjectID) will be visible. That resulted in the typical symbology issue you just faced.

A solid color symbology of HBP didn't allow you to see the symbology of INT OWND (which actually existed). On the other hand, the hashed symbology of the INT OWND (on top) still allowed you to see the symbols of HBP beneath them.

 

So, I have two workarounds.

Workaround-1 (Preferred):

Define a non-solid symbology for HBP as well (see screenshot below).

JayantaPoddar_0-1630078894125.png

 

 

Workaround-2 (Less Preferred):

If you want to keep the HBP symbology as solid color, then you need to sort the layer based on the Status field in ascending order.

This will put the INT OWND values on top. So, you will be able to see both the values.

* Note: This tool will change the order of the records (Feature parts) in the shapefile. That's why I mentioned it as a less preferred method.

JayantaPoddar_1-1630078894139.png

 

 

 



Think Location

View solution in original post

KarenHoelscher
New Contributor III

Since HBP has to be a solid color, I tested workaround-2.  I found that changing the order of the records in the shapefile does NOT negatively effect my other work with the shapefile. So going with the 2nd fix! Thank you again for your help. 

0 Kudos
KenBuja
MVP Honored Contributor

If you have to use solid colors, you could also look at the layer blending capabilities: https://pro.arcgis.com/en/pro-app/latest/help/mapping/layer-properties/apply-visual-effects.htm

We have a layer that has many overlapping features and by using the "Multiply" darkening mode, we can still see all the individual features.

KenBuja_0-1630086709594.png

 

 

View solution in original post

JayantaPoddar
MVP Esteemed Contributor

Ken's solution makes more sense. That could be your best and easiest option.

Feature Blend option (choose any darkening mode) under Appearance> Effects, should do the trick.

JayantaPoddar_0-1630091051762.png

 



Think Location
0 Kudos