Staging failed when trying to publish hosted feature layer in Pro

4085
11
02-26-2018 02:53 PM
AdrianWelsh
MVP Notable Contributor

I have about four layers I am trying to publish from ArcGIS Pro‌ to ArcGIS Online‌ and I keep receiving a "Staging failed" error with no other details:

I found this article:

Error: Staging failed 

I tried to run through the troubleshooting but none of these options worked.

Facts: I can publish regular data from a regular coordinate system.

I am using a custom coordinate system and converted CAD data into a file geodatabase.

I have never had an issue with publishing converted CAD data from a custom coordinate system.

I tried one layer at a time and it still would not publish.

Are there any other ideas on what I can try to publish this data to the web?

I've even tried overwriting an existing hosted feature layer and creating a new feature layer. I do not have time-enabled data (as far as I know). There is no custom symbology.

Thanks.

11 Replies
InmaculadaPareja1
New Contributor II

I just ran into this issue. In my case, I solved the issue by repairing the geometry of my polygon layer. Hope this can helps someone else.

BrandonBiron
New Contributor

I ran into this error as well. 

  • Cause: 
    • There was an FC with a relation table and attachment table that we renamed. We did rename the FC, attach table, and relation ref. However, it would not publish.
  • Solution:
    • Delete attachments table and relation reference. We were able to publish after doing that. 
0 Kudos