Publishing from Pro - "Federated Server Not Available"

1126
14
02-21-2020 12:17 PM
MichaelKnapp
Occasional Contributor

Hi there - 

We've typically created services from MXDs, but are testing publishing to our Enterprise Server from a Pro document. 

We have the data source registered in the data store, and the active portal in Pro is our enterprise portal logged in with an account that we've used to publish services from MXDs. 

When I go to "Publish Web Layer", we get the "Federated Server Not Available" warning. I did confirm that our federation is correct and functional. 

Any ideas as to what might be going on here? 

Using Pro 2.4.2

I'm not finding much online about this, which makes me think I must be missing something simple. 

Thanks!

0 Kudos
14 Replies
WillBooth1
New Contributor III

Hi Michael, 

Does your Active Portal have any federated servers, if so it should look something like this (although you can have more than one)?

Cheers

Will

0 Kudos
JonathanBailey_LimGeomatics
New Contributor III

Michael Knapp‌ Did you ever resolve this issue?

Will Booth I am having the same issue. I can confirm that, in my case, I have an ArcGIS Server site federated with Portal for ArcGIS.

0 Kudos
DuongHB
New Contributor II

Hi Jonathan,

I got the same issue like you. Having ArcGIS Server site federated with Portal for ArcGIS but still get "Federated Server Not Available" when publishing from ArcGIS Pro.

Before my ArcGIS Server is not a Hosting Server, and when I made it a Hosting Server, it works. So let try it for your temporary solution.

Regards.

0 Kudos
AndersBerg
New Contributor II

Did anyone find the answer to this? working with pro 2.5 and my portal is 10.7 and federated 

0 Kudos
George_Thompson
Esri Frequent Contributor

This is how you can publish from ArcGIS Pro to a stand-alone ArcGIS Server (ArcGIS Pro starting at 2.4.x+ and ArcGIS Server 10.6.x+). There are limitations to what can be published.

Publish services—ArcGIS Pro | Documentation 

Publishing to stand-alone server sites - https://enterprise.arcgis.com/en/server/latest/publish-services/windows/service-publishing-in-arcgis... 

Connect to a GIS server - Connect to a GIS server—ArcGIS Pro | Documentation 

--- George T.
0 Kudos
AndersBerg
New Contributor II

Thank you for the reply and this information. Although I am not sure that it applies to my particular case. I am working with a federated server on enterprise 10.7 and trying to published a layer from a database that is registered.( I can publish this same data from ArcMap, but for this particular instance I need to use pro). 

 

I get the error message "Federated server not available" when trying to publish. Any ideas what could be wrong or what settings I need to check?

0 Kudos
George_Thompson
Esri Frequent Contributor

You need to update the hosting server properties in your above screenshot. Once a hosting server is designated, the workflow should be successful.

--- George T.
0 Kudos
AndersBerg
New Contributor II

Ok, thank you for your help. To clarify, does this mean that I need a data store?

Configure a hosting server—Portal for ArcGIS (10.7 and 10.7.1) | Documentation for ArcGIS Enterprise 

0 Kudos
George_Thompson
Esri Frequent Contributor

Yes, I believe that you will need a DataStore configured for the hosting server.

In your publishing screenshot, you have it as "Copy all Data", if you change it to "Reference registered data" what is the outcome?

--- George T.