Problem Sharing as a Web Layer from ArcGISPro to Portal hangs at "Uploading service Definition"

234
4
05-11-2021 10:50 AM
Labels (1)
JoseSanchez
Occasional Contributor III

Hello everyone,

I am trying to share an sde feature class as a Web Layer in Portal from ArcGIs Pro.

I did the following set up to prepare the layer:

Versioned layer, added editor tracking and globalid field.

Right click layer and select Sharing as a Web Layer.

Versioning SDE connection Type: Branch

Reference Registered data: Map Image, Featured.

Configuration, Capabilities, Version Management checked.

Location: Folder in Portal

Server and Folder:
- URL for Federated Server
- folder in Federated Server

Then after publishing it it stays hanging in this step:  "Uploading service Definition"

Please advise.

Thanks

0 Kudos
4 Replies
jcarlson
MVP Regular Contributor

How long does it hang for? There are a number of factors that could slow down that part of the process. What is your Portal configuration like? Multiple machines? Cloud-based?

- Josh Carlson
Kendall County GIS
0 Kudos
JoseSanchez
Occasional Contributor III

Hi jcarlson,

It stayed hanging for more than 10 minutes and I decided to stop the process.

We are using an enterprise Portal, that is server based, not cloud based.

How do I find more information about this Portal configuration?

 Thanks

 

 

 

0 Kudos
MichaelVolz
Esteemed Contributor

Is this your first time using the right click Sharing as Web Layer procedure?  If not, is this the first time trying a branched versioned SDE feature class with editor tracking enabled?  I guess bottom line, what is different with this publishing process compared to your setup in the past?

0 Kudos
JoseSanchez
Occasional Contributor III

Hi Michael,

This is the first time I am trying to publish a layer  using ArcGIsPro.

And yes I did branched versioned SDE feature class with editor tracking enabled.

 

0 Kudos