Pro unable to see files or folders

552
6
03-22-2021 02:49 PM
AndrewBlowers1
New Contributor II

Recently, ArcGIS Pro has been unable to see local files, folders, etc. on my machine when attempting to save a project file, add data from local, or attempting to open an existing project file. I have ArcGIS Pro version 2.7.2 installed and my machine is running Windows 10 Enterprise Version 20H2. I have uninstalled and reinstalled, then let the program update itself to the most recent version. When installing, I have selected the option to allow the program to be available to all users. If I run the program as an administrator, the file explorer functions as expected but this is not a workable solution for me at this time. 

The attached screenshot shows the empty ArcGIS Pro file explorer when I try to save a project file or add data. 

Any assistance or troubleshooting tips would be greatly appreciated.

0 Kudos
6 Replies
DanPatterson
MVP Esteemed Contributor

on the top line, there is an arrowed circle which is "refresh"

It does nothing?


... sort of retired...
0 Kudos
AndrewBlowers1
New Contributor II

@DanPatterson Correct, using the refresh button just makes the file explorer "spin" endlessly. I read in another thread to try the F5 key but that doesn't appear to do anything. 

0 Kudos
DanPatterson
MVP Esteemed Contributor

When you did a "reinstall", did you rename folders in c:\users\....local\appdata\esri etc?

In arcmap you could reset your application profile in a similar way.

There is a link which describes the process for a variety of situations.... check this

Problem: ArcGIS Pro freezes on the initializing screen before the Sign In dialog box displays (esri....


... sort of retired...
0 Kudos
AngelaMarsh1
Esri Contributor

Hi Andrew,

This isnt an exact fix, but heres some workarounds to try.

Add a folder connection in your Catalog pane. Once the folder connection is established in catalog, you can access this location through your project connections (see attached).

AngelaMarsh1_0-1616471955075.png

Something else to try, is to go into your Options settings in Pro and select where you want your project files to automatically save and/or unpackage. Ive attached some screenshots of where to find these settings also. Im not sure if this will help with your existing issues, but it may help you work around them or it may help ArcGIS Pro direct itself to your desktop location.

Good luck :) 

Happy Mapping
0 Kudos
Robert_LeClair
Esri Frequent Contributor

By chance do you have XTools for Pro (or ArcMap?) installed?  If so, uninstall XTools and try to add data again.

0 Kudos
Ana_Villa
New Contributor II

Any answer? I have the same problem!

0 Kudos