Pro crashes after adding text to layout and annoying "Active edit tool is filtering the selection" after ArcPro 2.7 Upgrade

1154
11
Jump to solution
12-22-2020 01:18 AM
Katrin
by
New Contributor III

After upgrading to version 2.7 I have encountered two major errors that have already taken a lot of extra time and made working with Pro much slower:

 

"Active edit tool is filtering the selection" notification after using Edit Vertices.

I am reviewing a dataset and repeatedly going through a workflow of:

  1. Editing a line feature using Edit vertices
  2. Updating the attribute table of the feature
  3. Updating another table linearly referenced to the same feature. For that, I need to select the feature by attribute in another table. 

When using the select by attribute after I have edited vertices, I keep getting the notification "Active edit tool is filtering the selection" which did not appear before the update. I understand that now I need to 'deactivate the current tool by pressing Esc'. However, this is very clumsy. If I edit the feature by vertices, I complete my edits by pressing enter or the green tick symbol, so the edits are done and the shape length updated in the attribute table. By that point the vertices do not appear on the feature anymore and it seems that the tool is closed, but it is not and still filters the selection, apparently. I therefore need to activate the edit vertices tool again and normally press Esc many times before it deactivates the tool and I could go on with my work. I also tried to press Esc when I have corrected the vertices (instead of pressing enter) but in this case the changes don't apply.

Any ideas how I can deactivate the tool right when I have done the changes? Before it worked nice and smoothly, why is this change necessary? I am going through these three steps I described hundreds of times and I am losing a lot of time now.

Unable to edit text on my layout

Does anyone have the same problem? Pro crashes immediately when I am editing text in my layout view. Furthermore, every time when I have tried to send an error report, it fails to send it. It happens very quickly: I choose to draw the text box and immediately when I am done drawing it, Pro crashes. I also tried to add Scale from the dynamic text options, which worked. However, when I tried to edit the text in Scale (I need to translate the word 'scale') Pro crashes.

Two pictures to illustrate the crash in layout view:

1. Adding text box

Trying to add text to my layoutTrying to add text to my layout

 2. Pro crashes the second I release my mouse to finish drawing the text box

Crash literally the second I finished drawing the boxCrash literally the second I finished drawing the box

 

If somebody knows a solution, I would appreciate, because I really need to export my maps.

Thanks!

 

0 Kudos
11 Replies
TomBole
Esri Regular Contributor

Hi Huanglei, 

Sorry that you are running into this serious issue. As Steinþór states one possible solution "... is to add English  to the Preferred languages in Windows Language settings."  However, based on Steinþór"s experience it may not work in all cases. This has been an exceedingly difficult bug to reproduce - unfortunately we do not have test environments that replicate all possible OS configurations. We are working hard to fully understand what went wrong so we can address this in our testing so we can catch issues like this before the software is released.

In situations like this it is vital that we get information from people experiencing the problem. We believe we have fix and hope to have it out with the next service patch. However, it is hard to validate a fix if you could not reproduce the problem in the first place. This is extremely frustrating for everyone!  

The more information Technical support and the development team get the better we'll understand the problem and the better the fix will be. If possible please contact Support. They can be contacted at https://support.esri.com/en/contact-tech-support. The issue is BUG-000136460.  If you have already contacted them - thanks!

Tom

MicheleHosking1
Occasional Contributor

Any solution to the Active edit tool is filtering the selection issue? This is driving me crazy.  I split a polygon and now I can't select a feature in another layer without this annoying message popping up and my point won't select.  I have hit ESC many times and it will not go away.  Do I have to close my project just to make this annoying and extremely unnecessary  feature go away? Why do ESRI insist on 'fixing' things that weren't broke?

0 Kudos