Notes not appearing on map uploaded from ArcGIS Pro to online map viewer

54
2
07-01-2019 04:18 PM
Highlighted
New Contributor

I am having an issue with "notes" not uploading to an online map. I made 128 notes on the map using the point tool. When I uploaded the map the attribute table for all of the points is there, but the points do not show on the map. They appear in the Content and the Legend, but not actually on the map itself. I've tried zooming in and out to see if it's a visibility range issue, but that does not seem to be the case.

Reply
0 Kudos
2 Replies
Highlighted
Esri Notable Contributor

Hi Lynne,

It looks like sharing the map notes layer directly isn't currently supported - this is something that the dev team is working on.  So if you were to try to share the notes layer directly, you'd see that it is grayed out and there is a hover tip explaining that it isn't supported:

The workaround for now would be to look at the source feature class for your notes.  Then add that feature class back to the map, and you should be able to share that:

If you had a number of layers that included map notes, and then you used the Share As Web Layer from the ribbon, there would have been a warning that the notes layer wasn't supported and so it would have been dropped.  I *think* maybe that is what is going on, though strange that the table shows up?

Anyway, try the workaround of adding the source feature class, removing the notes layer, and re-sharing.  Does that work?

Reply
0 Kudos
Highlighted
New Contributor

My map doesn't have the same options that your example shows. I also couldn't get a screenshot of the "Sharing" options, but when I right click on the Mystery Drains, the only Sharing options are Save as Layer File and Share as Layer Package. It also doesn't show a point, as you can see in the screenshot I took. My menu has far less options than your example (ie; nothing about charts, reports, tables, data, or labels), so I'm wondering if I did something wrong when I was adding these points to my map. 

Reply
0 Kudos