Not supported Feature Layer type when sharing a web feature layer

113
4
02-20-2019 05:02 AM
New Contributor

Hi, I'm trying to share a web feature layer from ArcGIS Pro to an enterprise server, but the only available Layer type is Map Image. I want to share it as a Feature Layer type. What could be the problem with inactive Feature checkbox?

sharing a feature layer

Tags (1)
Reply
0 Kudos
4 Replies
New Contributor III

Hi Daniela Petrova,

What version of Portal are you using? Is your Portal federated with ArcGIS Server? And is the server specified your Portal hosting server?

What type of data is in the map (feature class, raster, or both)?

As a test, can you publish to ArcGIS Online as a hosted feature service?

Best,

Morgan

Reply
0 Kudos
New Contributor

I'm using v.10.6.1. 

My Portal is federated with ArcGIS Server, but the server is not set as a hosting server, because it is not appeared in the dropdown menu:

federated server

The data that I want to share are all of type feature classes.

Furthermore, I've configured Relational and Tile Cache Data Stores and all are validated successfully:

data stores

I cannot publish to ArcGIS Online for testing purposes, due to my account does not have publishing privileges.

 

Reply
0 Kudos
Esri Contributor

Hi Daniel,

If you do not have a hosting server and are publishing to a federated server, you will only be able to publish:

Reference registered data: Map Image, Feature

Copy data: Map Image

The combination of Copy + Feature is disabled because that would publish a web feature layer (hosted).  

For your workflow, if you need to copy data, you may want to try publishing a Map Image Layer and then access the feature layers of the service directly.  

Reply
0 Kudos
New Contributor

Now I'm accessing the feature layers directly from Map Image layer indeed, but the application is extremely slow. A large part of the requests are canceled:

requests canceled

When I want to get some info with the popup I need wait > 60 sec?!

What could be the reason of canceled requests? I'm pretty sure that the server and/or service have not appropriate setup.

If I use a hosted server, will it improve the performance? And what are the requirements to set arcGIS server for hosted server, because it is not appeared as an option in a dropdown menu.

Reply
0 Kudos