Map is not loading?

5505
17
Jump to solution
08-29-2019 05:02 AM
AdamRepsher
Regular Contributor

Hi Everyone,

(this is Pro v2.4.1)

Yesterday afternoon, I just opened an ArcGIS Pro project and saw this...

...for 15 minutes.

I could change Portals, look through the Catalog, change Portals - but the Map never loaded.  I had to open Task Manager and kill the app.  ArcGISCleanup was running too.

I created a new project and encountered the same thing.

It doesn't crash, it just never loads a map.

Has anyone else seen this behavior - or have a solution?

Thanks,

--Adam

0 Kudos
17 Replies
ThomasColson
MVP Frequent Contributor

David, it would be helpful if you could get a case going as well. There are very data/environment specific issues that TS will collect with SDE Intercept and SQL Trace that will inform development specifically where performance issues are, and as you can tell, Pro is getting a lot of shade thrown on it for performance issues. I don't quite have a reproducible case as you two do. Reference this thread with TS, it will help them know what troublshooting has already been done. Same for SDEIntercept, it is best that TS walks you though how to set it up, I only look at how fast the trace files are being generated, only ESRI can interpret the file contents. 

AdamRepsher
Regular Contributor

Hi David,

I will let you know as soon as I get to a resolution.

--Adam

0 Kudos
deleted-user-ETabldQ2WIq7
New Contributor II

Adam, 

An update, as of this morning, I am now able to successfully load my projects into ArcGIS Pro.  Similar to what you mentioned in your thread, our IT group recently updated Windows on my machine (Build 1903).  This morning I updated my Windows installation with two of the automatic updates - one for Windows (KB4512941) and one for .NET (KB4511555).  After the installation and re-boot of the two updates, I was able to successfully open a project and load a map.  These two items were the only changes made to the system between Pro not loading a map, and loading a map. Prior to that I exhibited the same behavior you described.  Not sure if this helps or adds to the mystery....

Dave

AdamRepsher
Regular Contributor

It turned out to be Video drivers - one of the first things I should have evaluated.

The catch is - It was not the one for the NVIDIA card, the one that is used for most of the heavy lifting in Pro.  It was the one on the motherboard!  I updated the NVIDIA first with no effect.  I just updated the on-board video drivers because they were in the list and easily accessible.  On a whim, I restarted and ran Pro.  It worked!

Thanks to all!

--Adam

View solution in original post

TomaszTARCHALSKI1
Esri Contributor

Hi since everybody now is at home (mars 2020) , I am using the PRo from home, and I noticed the same issue. the behaviour is as follow:

- State 1

  • not using internet for anything
  • opening ArcGISPRO - no problem

State 2

  • using internet  (runing geocodage or having conference using TEAMS)
  • opening PRo - PROBLEM - "loading maps" for ever, so in fact I cannot open it.

WHY IS IT trying to load maps, if they are off ????. I tried to change setting prior opening new document. still the same.

thank you for looking at it.

ValCannon2
New Contributor III

It is good to know that I am not the only one. I get extremely long "loading maps" messages from sde maps services that I am connected with via VPN. I also tried to import a feature class to a local file gdb from an sde server via ArcGIS Pro catalog and it took almost an hour. But it was almost instant when I copied it via SQL Server to a local install and then imported it to the file gdb.

Working from home has opened up a whole new set of problems with ArcGIS. But it still sounds like the eternal "loading maps" is a bug that if nothing else should give you an error that tells you why it isn't loading after...maybe five minutes?

0 Kudos
Rafael_Nunes
New Contributor

Hey Adam. How are you?

Hope that everything is fine. I had the same problem. I've tried several versions of ArcGis Pro with the same result: 'map loading' forever...

I've also tried to update the motherboard video driver and nothing... Just to help others that may have the same problem: check for Internet Explorer updates. If your IE, for exemple, is the 8 you will have problems... 

That's how it was solved for me. But how is that possible? Do not have a clue! But the IE version (11) is mentioned as a requeriment for the software to run. 

Best regards!

0 Kudos
KamillePreto
Occasional Contributor

Has anyone found a solution to this outside of the video card issue?

My video cards were just recently upgraded and that fixed a lot of my previous issues. But this is something that I am still dealing with heavily. I cannot get into my project.

0 Kudos