Manually adding RGB values to a raster attribute in ArcGIS Pro

224
2
Jump to solution
06-24-2021 08:03 AM
IGCMCGIS
New Contributor III

Hello Everyone,

We are publishing image services with raster attributes defined as this NLCDL Sample where both the RGB values and Classes reside with the raster attributes.

Our rasters do have the Class but no RGB values in their attributes. Is there a way to add these RGB values manually in the attribute table within ArcGIS Pro?

We did add them to an img file using ERDAS Imagine but publishing it as an image service from ArcGIS Pro does not show us the attribute table. This issue occurs even while exporting the raster in ArcGIS Pro to a TIFF.

We are sure this can be done in ArcGIS Pro only and it would be great if you could let us know if we are missing something or is there a set workflow to manually add the values.

0 Kudos
1 Solution

Accepted Solutions
IGCMCGIS
New Contributor III

Thanks @JayantaPoddar ,

You can essentially do this using the Attribute Table property from the Raster Functions.

Whitin the Attribute Table parameters you can directly add the values manually and choose the respective color. 

I then ran an Export Raster from teh new layer and then published the image service and it worked fine.

Thank you!

View solution in original post

2 Replies
JayantaPoddar
MVP Esteemed Contributor

You may try something similar to How To: Create a colormap index within the attribute table of an integer raster 



Think Location
IGCMCGIS
New Contributor III

Thanks @JayantaPoddar ,

You can essentially do this using the Attribute Table property from the Raster Functions.

Whitin the Attribute Table parameters you can directly add the values manually and choose the respective color. 

I then ran an Export Raster from teh new layer and then published the image service and it worked fine.

Thank you!

View solution in original post