locked legend items

3681
37
02-10-2020 02:55 PM
DanAllison
New Contributor III

I have a ArcGIS Pro 2.5 map in which legend items (group layer name, layer name, etc.) are locked. They are checked but grayed out. See attached snips.

I have tried deleting the legend and creating a new one. I have tried creating a new layout. I have tried removing layers and re-importing them from the database. I have re-started the application. None of these has solved the issue.

Tags (2)
37 Replies
BranislavBlagojevic
Occasional Contributor

Tom,

Thanks for question.

No! Only on the geonet.

Greeting!

Reply
0 Kudos
KoryKramer
Community Moderator

Hi Branislav - part of your agreement to participate in beta testing, is to use the Early Adopter Community (EAC) forums to report and discuss issues.  I'd encourage you to direct feedback about a beta version of the software to the EAC forum rather than GeoNet. 

That said, from your post about the release notes, it isn't clear whether you have tested the functionality discussed on this thread, using Pro 2.6 beta.  If you have not, I'd encourage you to do so, as testing new/fixed functionality and providing feedback on said functionality through the EAC forum is the primary purpose of participating in the beta.  If you discover usability issues when testing the beta version, please provide that feedback directly in the forum, as product teams are monitoring those forums and make their best effort to assist in resolving issues. We appreciate your participation and your willingness to participate in ArcGIS Beta Programs, which helps Esri make better products.

Thank you!

Reply
0 Kudos
ElizabethWheeler
New Contributor II

A different workaround is to select all those layers within the legend.show properties and the group layer name will toggle back for you to disable it.

VanessaGiles1
New Contributor II

Oh wow!  That actually worked.  Very simple and easy and more efficient than doing them individually.  Thank goodness - it was pretty frustrating not being able to make a nice, functional legend. 

Reply
0 Kudos
Arne_Gelfert
Regular Contributor

You're referring to this?

That selects all the entries in legend but doesn't undo they greyed out 

Reply
0 Kudos
BranislavBlagojevic
Occasional Contributor

Kory,
Thanks for the note. YES! You're right about the EAC ... but it's just your response to @ Shayan Seyedi on May 11, 2020 in which you say "It looks like it will be fixed when 2.6 releases in a couple of months", as well as the post of Vanese Giles (see above) inspired me to write this on the forum where the discussion started (GeoNet) and where you, personally, invite users to report problems with ArcGIS Pro and where some explanations of these problems are actually expected.
Concerning the EAC, let me also praise the development team; they really try to solve problems! That is indisputable! However, many small things, such as this one named with "locked legend items" or with "setting up the attribute-driven color in symbology", etc. (essential in daily cartographic production), seem, in personal experience, to remain invisible to them. This is understandable, because new options and possibilities are predominantly discussed at the EAC forum and incomparably less existing problems - BUGS.

Regards.

KoryKramer
Community Moderator
Reply
0 Kudos
AmilynnAdams
New Contributor II

Soooo...this inability to select/de-select the group layer from displaying was a known bug nearly a year ago.  I've encountered the same thing now in Pro 2.7 and have been pulling my hair out until I found this post.  Is this going to be fixed anytime soon?  

Reply
0 Kudos