Legend is not displaying layers, only displaying the labels

130
4
Jump to solution
2 weeks ago
Labels (3)
AsiaFoster
New Contributor

I have been trying to create a legend that displays all of my attribute information to display in the legend under one label; however, I am only able to see the Labels, no layers. These layers (per label) are symbolized the same. For example, there are 3 facilities listed under Health Center (all symbolized the same), so forth, and so on. However, only the Health Center (label) is showing in the legend, none of the 3 facilities will display.

I have a strict deadline and that is the only thing holding me back.

Please assist,

Thank you.

0 Kudos
1 Solution

Accepted Solutions
TomBole
Esri Regular Contributor

Hi Asia, 

The legend pulls it information (symbols, and text: layer name, labels, descriptions) from the symbology of the layer.  Often what you see in the Contents pane (TOC) is what you'll see in the legend (on the layout page).

Without seeing your data and how you are symbolizing your layer (facilities?) it is impossible to troubleshoot legend issues.  Can you provide a screenshot of Contents pane and the legend?

Tom

View solution in original post

0 Kudos
4 Replies
TomBole
Esri Regular Contributor

Hi Asia, 

The legend pulls it information (symbols, and text: layer name, labels, descriptions) from the symbology of the layer.  Often what you see in the Contents pane (TOC) is what you'll see in the legend (on the layout page).

Without seeing your data and how you are symbolizing your layer (facilities?) it is impossible to troubleshoot legend issues.  Can you provide a screenshot of Contents pane and the legend?

Tom

View solution in original post

0 Kudos
SarahHartholt
Occasional Contributor II

Hi Asia,

If you are using ArcGIS Pro you may need to configure how the items appear in your legend. In the Contents pane expand Legend. First ensure that the layer is turned on (box is checked) then right click on the layer and click properties. Ensure that the box next to label is checked and you might want to turn off Layer name

SarahHartholt_0-1623435780142.png

 

AsiaFoster
New Contributor

Thank you, this was helpful. I was able to perform what I needed.

0 Kudos
TomBole
Esri Regular Contributor

Glad you were able to get what you needed!

0 Kudos