Label Objects for Deep Learning , Output Strings are using , (comma) instead of .(point)

137
3
2 weeks ago
Bobblet11
New Contributor

I have been labaeling Objects with the "LAbel Objects for Deep Learning" classification tool on ArcGIS Pro. After exporting the Training Data, I can't use it further, because the output strings are sepparated by , and not by .

<object>
<name>1</name>
<bndbox>
<xmin>161,32</xmin>
<ymin>128,12</ymin>
<xmax>181,01</xmax>
<ymax>147,81</ymax>
</bndbox>
</object>

When I try to import the data for new tools, ArcGIS will can't read the data correctly, since the numbers are sepperated by , and not by .

I changed the language setting to Englisch in ArcGIS and on my PC.

 

Does anybody know how i can solve this problem, so i get coorect separated numbers or that ArcGIS reads the exported data shown above.

Thank you

Robert

0 Kudos
3 Replies
Tim_McGinnes
Occasional Contributor III

Changing the language may not be enough - somewhere in your Windows regional settings there should be a setting for the decimal symbol - make sure it is set to the point and not the comma. You will have to export your training data again.

Tim_McGinnes_0-1623156256569.png

Make Export Training Data's output independent from OS decimal delimiter setting 

0 Kudos
Bobblet11
New Contributor

Thank you for your Answer. The Decimal symbol was allready set to "." (point), I checked it and tried exporting again, but it still won't work. The numbres are still sepearated by ,

0 Kudos
DanPatterson
MVP Honored Contributor

check Geoprocessing in different locales and regions—ArcGIS Pro | Documentation

It might be worthwhile confirming your locale settings.  If English is set locale will return (None, None).  Importing arcpy and checking again will confirm your locale.

import locale

locale.getlocale()
(None, None)

import arcpy
locale.getlocale()
('English_Canada', '1252')

... sort of retired...
0 Kudos