I would like to use FIDDLER with ArcGIS Pro, does anyone know how to do it?

1943
7
Jump to solution
02-04-2017 11:52 AM
MiguelParedes
Occasional Contributor II

I am trying to troubleshoot a connection issue to a WMS service, and I would like to sue FIDDLER to examine the communication traffic between Pro and the WMS host.

In ArcGIS Desktop I do not have to do anything, however, in Pro there must be some settings that are required because I cannot see any traffic coming from Pro.

Any guidance would be greatly appreciated.

Tags (3)
1 Solution

Accepted Solutions
RobertKrisher
Occasional Contributor

I've had some success by setting up a proxy in the ArcGISPro.exe.config file based off of the instructions that come with fiddler ( http://docs.telerik.com/fiddler/Configure-Fiddler/Tasks/ConfigureDotNETApp ).  I added the following snippet after the system.xml element in the config file and it allowed me to start intercepting more web calls than I was able to previously:

  <system.net>
   <defaultProxy>
    <proxy autoDetect="false" bypassonlocal="false" proxyaddress="http://127.0.0.1:8888" usesystemdefault="false" />
   </defaultProxy>
  </system.net>

View solution in original post

7 Replies
DougBrowning
MVP Frequent Contributor

Fiddler should trap absolutely everything.  It could be that it is https?  There are instructions with Fiddler on decoding that.

Maybe the fact there is no traffic is your issue.

Reply
0 Kudos
MiguelParedes
Occasional Contributor II

Greetings Dough,

Thanks for the suggestion. Fiddler is already set up to decode HTTPS traffic. I can capture traffic from ArcGIS Desktop, accessing the same sample WFS service, but with Pro 1.4, there is not such joy. Not so far, that is.

Miguel

Reply
0 Kudos
RobertKrisher
Occasional Contributor

I've had some success by setting up a proxy in the ArcGISPro.exe.config file based off of the instructions that come with fiddler ( http://docs.telerik.com/fiddler/Configure-Fiddler/Tasks/ConfigureDotNETApp ).  I added the following snippet after the system.xml element in the config file and it allowed me to start intercepting more web calls than I was able to previously:

  <system.net>
   <defaultProxy>
    <proxy autoDetect="false" bypassonlocal="false" proxyaddress="http://127.0.0.1:8888" usesystemdefault="false" />
   </defaultProxy>
  </system.net>

View solution in original post

MiguelParedes
Occasional Contributor II

Greetings Robert,

Many thanks for the snippet.  I have implemented it on my install of Pro 1.4, and I can say that it is working like a charm.

I am now able to intercept the calls to my OGC services running on my own machine and other servers. 

So I would say that yes, your snippet works, and I am now able to monitor communication from ArcGIS Pro 1.4 via FIDDLER, which is of great use for testing.

Many thanks again for such useful piece of information.

All the best.

Reply
0 Kudos
KirkKuykendall2
Occasional Contributor

HelloMiguel Paredes‌ !

Are you (or Robert Krisher) able to get this running with 2.4.2?

I get this at startup:

Hope you are doing well,

Kirk

Reply
0 Kudos
KirkKuykendall2
Occasional Contributor

Nevermind.  Fixed it by moving the system.net element so that it is AFTER the configSections element.

RuiMenezes
New Contributor III

Hi all

Sorry if this off-topic but I'm trying to run Fiddler and I'm unable to run it with a local account. Can you run Fiddler with a local account or do you have to use an admin account?

Thank you very much

Kind regards,

Rui

Reply
0 Kudos