Hyperlinks in ArcGIS Pro

74
3
06-18-2020 08:08 AM
ToddHill
New Contributor

I have 100's of layers that have Hyperlinked pictures inside ArcGIS Desktop. These picture sit inside a NAS in my office. The workflow to (Hyper)link these pictures in Desktop is very easy, but for some reason I must be missing something from all the threads I have read when trying to do the same thing in Pro. I'm slowly transitioning to Pro right now and one of the few challenges that I have had using Pro has been getting these hyperlinked pictures to work. 

Anyway if anyone can point me in the right direction I would really appreciate it.

Thanks,

Todd 

Tags (1)
Reply
0 Kudos
3 Replies
JoshuaBixby
MVP Esteemed Contributor

What exactly isn't working?  Can you view the hyperlinked images in Pro that were created in ArcMap?  Is the issue with adding the hyperlink to images for new records in Pro?

Reply
0 Kudos
ToddHill
New Contributor

No I can't view the image in Pro(I Can in Desktop). The hyperlink is already in the attribute table see the picture below.

Hyperlink - Pro Att Table

The issue is with getting the hyperlinks to work inside Pro.

Thanks,

Todd

Reply
0 Kudos
JoshuaBixby
MVP Esteemed Contributor

Have you read:  Configure pop-ups—ArcGIS Pro | Documentation ?

What you have in the text field is a UNC path, which an application can turn into a hyperlink, but ArcGIS Pro does not treat UNC paths as hyperlinks.  If you put an HTTP-based URL, then Pro would treat it as a hyperlink.

Since Pro doesn't treat UNC paths as hyperlinks by default, you can configure the pop-up window to have it treat that UNC path the way you want.

Reply
0 Kudos