How to center align legends in ArcGIS Pro 2.2.2

2232
17
09-25-2018 01:26 PM
New Contributor III

I've been working with Pro for a few months now and recently ran into an issue after upgrading from 2.0 to 2.2.2. While the legend items used to center when there was only 1 column, now they always align left. I've tried every option I can think of to resetting "Size & Position" to top center, to setting Text Symbol - Position to center horizontal alignment. 

I've included two screenshots, the first of a map legend from 2.0 and the second of the same map legend in 2.2.2 with no changes made to any layout/legend settings.

If this is a new setting I can change, I'd really appreciate anyone who can point it out. Thanks.

Reply
0 Kudos
17 Replies
MVP Regular Contributor

If you open the legend properties and select 'Placement' tab.  You'll see a box which you can choose where to set the items inside the legend frame.

EDIT: I now see the 'Size & Position' tab you're speaking of.  It seems to be the same as the 'Placement' tab in the Legend Pane.  If this solution doesn't work, I don't know if another solution and am curious as to why it's happening.  However, this solution did work for me.

New Contributor III

Thanks for the reply Mitch. The placement and Size & Position tabs seem to offer the same functionality. It's strange cause when I set the position to the center or bottom rows the contents adjust accordingly, but they won't shift right no matter whether I set the center or right columns (see screenshots).

Bottom-Left Alignment:

Top-Right Alignment:

Reply
0 Kudos
by
New Contributor III

Same issue here, only my legend items are stuck on the right and I can't align them to the left

Reply
0 Kudos
Esteemed Contributor

Has anyone tested creating a duplicate aprx from scratch in the latest version of Pro to see if the legend still does not get aligned as you would like?  I'm just wondering if it's the aprx existing in multiple versions of Pro that is causing the issue.

Reply
0 Kudos
MVP Regular Contributor

Was this layout (legend included) imported into ArcGIS Pro from an .mxd file?

Reply
0 Kudos
New Contributor III

The layout file was based on an mxd import. I just recreated the initial problem in an mxd-based layout in Pro 2.2.3. When I inserted a new Legend, the column displayed properly down the center; then I discovered that the issue seems to be related to the legend title. When I don't show the Legend title a single column will center properly. However if I show the title then a single column will always left align.

Esteemed Contributor

Has anyone created an incident with ESRI technical support about this issue?  ArcMap allows the layer names to align properly whether the Legend has a title or not.  I am still seeing this behavior in Pro 2.3 Beta within Early Adopter program.

MVP Regular Contributor

Yeah- this is definitely a bug (or should be).  I can replicate the issue on my end using ArcGIS Pro 2.2.4.

Esri Regular Contributor

FYI - Esri Support has the following defect reported at version 2.2.3 for this issue:

BUG-000117975 The right and middle positioning options (top, center, and bottom) stop working when the option to show the title of legend is checked.

The current status is "In Product Plan", meaning it will be fixed in a future release of ArcGIS Pro. If you'd like to track the status of the defect, please contact Esri Technical Support at 888-377-4575.