How do get geopackage layers to display in ArcPro 2.3.0?

1249
5
04-04-2019 10:37 AM
SFM_JonathanGoergen
New Contributor II

I am trying to load layers from a geopackage into ArcGIS Pro v2.3 to perform some geoprocessing.  When I add the layers to the map they appear in the table of contents, but do not display on the map canvas.  When I try and open the attribute table I get an error, "Shape integrity error" (error image below).  I fixed the geometry of the layers and tried again.  This still resulted in the same error.  When I tried to open the data in ArcMap 10.5.1 everything worked fine - the layers loaded, rendered, and the attribute table was viewable.  Accessing the data also worked perfectly in QGIS 3.4.  Is there a way to get geopackage data to display in ArcPro?  I can geoprocess in other environments but for publishing services to AGOL I would prefer to have the ability to use ArcPro to publish data stored in a geopackage due to the more flexible and complex symbology options available in ArcPro versus ArcMap.   

Tags (2)
Reply
0 Kudos
5 Replies
Robert_LeClair
Esri Frequent Contributor

In AGP, there is a Create SQLite Database GP tool with a parameter to create a GeoPackage database (1.0, 1.1, 1.2).  I wonder if it's a "version" issue?

Reply
0 Kudos
KoryKramer
Community Moderator

See the explanation here: https://support.esri.com/en/bugs/nimbus/QlVHLTAwMDExOTQwNg==

I'm wondering if you'd be able to create a new geopackage in 2.3 and move the features into that... so that if the writing happens in the current version, it would work???

Reply
0 Kudos
KoryKramer
Community Moderator

Also, as for the ultimate goal of publishing the geopackage, it doesn't look like that is currently supported: 

I'd recommend posting that as an idea on ArcGIS Ideas‌ in the Desktop category.  Would be handy to have.

Reply
0 Kudos
BruceHarold
Esri Regular Contributor

Just a note in passing, Geopackages are supported as static items in ArcGIS Online, so you can directly share them this way, and given valid geometry you can apply symbology from a layer file (for example).

Reply
0 Kudos
JohnSobetzer
Regular Contributor III

I get the same error trying to read a geopackage file created by another person in QGIS 3x.  ArcMap 10.6.1 will give me a longer more detailed error message, and then show me the table but not the polygons.  QGIS can use it fine, and convert it to a shapefile that ArcGIS can read.

Reply
0 Kudos