Geocoding in ArcGIS Pro

938
14
09-04-2018 10:19 AM
New Contributor II

I am trying to geocode an excel sheet imported in ArcGIS Pro 2.2.1. It has the following columns: ID, Address, State, Zipcode, and County. I even removed the other fields like "Description" and etc. cause I thought they might create problems because they contained special characters.  

I have tried different formats like CSV, XLS, and XLSX. None of them worked.

I have the following licensing as well: 3D Analyst, Geostatistical Analyst, Spatial Analyst, etc. Also, I am already logged in.

I followed the requirements for the excel sheet formatting and how to import them into ArcGIS pro; i.e. no spacing in the header row.

I right click on the table and choose Geocode Table. The Input Table is choosen by default. I choose "US Address" from All Portal as Input Locator (I had no idea how to work with this because in ArcMap everything was set as default, so in ArcPro, I just looked it up and figure out that US address might work). After that, I set every other parameter and Routing Location as Preferred Location Type, and click RUN. But I keep getting this error:

ERROR 000010: Geocode addresses failed.
Failed to execute (GeocodeAddresses).
Failed at Tuesday, September 4, 2018 11:15:51 AM (Elapsed Time: 1.07 seconds)
Error: 10 - Geocode addresses failed.
Error: -2147467259 - Failed to execute (GeocodeAddresses).

Do you have any suggestions?

Here, is a snapshot of the data:

IDAddressCityCountyStateZipcode
1922 North Main StreetBrigham CityBOX ELDERUtah84302
2780 East 100 NorthPaysonUtahUtah84651
31510 North 800 EastLoganCACHEUtah84322
45600 South Redwood RoadTaylorsvilleSALT LAKEUtah84123
574 East Main StreetAmerican ForkUtahUtah84003
6289 South State StreetClearfieldDAVISUtah84015
Tags (1)
Reply
0 Kudos
14 Replies
New Contributor II

Actually, it is available and I just tested it again.

Reply
0 Kudos
Occasional Contributor

Thanks Nasser, so just to confirm, when you right-click the table > Geocode Table, and it opens the Geocode Table pane, you don't see an option for the "ArcGIS World Geocode Service" in the Input Locator drop-down?

Can you confirm what Active Portal you are using in ArcGIS Pro? If you go the blue "Project" button in the very top-left corner of ArcGIS Pro and hit the "Portals" tab, ensure that "https://www.arcgis.com/" is set as the active portal and this is the one you are signed in with. If you needed to switch to this portal from something else, it'd be good to restart Pro after changing it to re-load the locators. 

 

-Eric

Reply
0 Kudos
New Contributor II

No, Eric, it is not there. I should click on the folder and search that term in the "All Portal", and still I don't find it.

I double checked that. ArcGIS.com is my only available portal and it is active.

Reply
0 Kudos
Occasional Contributor

At this point it would probably be good to get in contact with one of the Administrators of the ArcGIS Online account you are using to sign into ArcGIS Pro with and ensure:

  1. You have a role with the "Geocoding" permission (most of the default roles will have this permission turned on, really only applies if your organization is utilizing custom roles) 
  2. The ArcGIS World Geocode Service has been added to your organization settings
    1. Log into arcgis.com with Administrator credentials
    2. Organization tab > Settings > Utility Services
    3. If you don't see ArcGIS World Geocode Service listed, add it via "Add Locator"

Reply
0 Kudos
New Contributor

Nasser Sharareh‌ Make sure to remove special characters from the Date on the CSV file.  For instance, your file name should read Nasser CSV 112719 rather than Nasser CSV 11-27-19.  I had this same error until I realized there were special characters in the file name making it invalid.

Reply
0 Kudos