Feature class to feature class not working in modelbuiler arcpro

08-19-2019 02:46 PM
New Contributor III

I created a model in modelbuilder that takes a feature service off of AGOL into a new fc, spatial joins it to another dataset on my pc to retain unique identifiers of the feature service, and then separates it into two new datasets, one to append to the original feature service if it does not overlap with existing points, or one to join in order to update attributes. 

To make these two new datasets, I'm ultimately doing a feature class to feature class tool with an sql expression of SARPUniqueID is null and another for SARPUniqueID is not null. However, when I run the feature class to feature class, it throws a cannot create output error.

Ive tried changing name character lengths, changing output locations, restarting, pretty much everything. When I try to run this tool with the same sql outside of model builder, it works just fine.

any advice?

Here is my screenshot

0 Kudos
0 Replies