Explore/selection tools return unexpected results on query feature class

08-21-2019 07:31 AM
New Contributor II

I'm trying to identify features within a query feature class in Pro, but every time I try to use either the Explore tool or the Select tool something weird happens with what appears to be selected or identified. The contents pane listed by selection says there's only one feature selected, the attribute table has every record selected but only lists along the bottom that one is selected, and the map view shows all features outlined in the selection color. Plus every time I refresh the map view with one selected record highlighted, the table updates so that every feature becomes highlighted.

Can someone help me figure out what the heck is going on!? I've tried restarting Pro and my computer, logging out and back into our portal, removing and re-adding the layer to my project; nothing's worked so far. I also don't have the same issues when using another feature class that's stored in our local SDE database, but it does the same thing with a second query feature class from the same db as the first.

Is this a problem specific to query layers in Pro? I've never had similar issues with these layers in ArcMap.

0 Kudos
0 Replies