Elevation Surface not showing in Properties

777
7
12-18-2018 10:03 AM
New Contributor

Hello,

 I'm trying to display a TIN layer in 3D. I have it shown under 2D layers, but am having a hard time making it appear in 3D. I've scene several tutorials online and they seem to indicate that there is a "Elevation" tab in map properties. But, there is no setting in my project. Am I missing something?

I've also tried setting my TIN layer as my elevation surface, but the view just loads indefinitely.

Help would be appreciated, thank you.

Tags (3)
Reply
0 Kudos
7 Replies
Esri Contributor

Hi Jonah,

Are you in a Map or a Scene? Scenes will have the Elevation tab in the properties, but Maps won't. Try doing this:

  • Select the Insert tab from the top of Pro
  • Drop down the New Map menu and select New Local Scene
  • Add your TIN to the new local scene. Does it appear in the 3D layers?

Here's the documentation on Elevation Surfaces (link 1) and in particular (link 2), how to use a TIN or DEM as the elevation surface in a Scene:

Elevation surfaces—Properties of maps | ArcGIS Desktop 

http://pro.arcgis.com/en/pro-app/help/mapping/properties/elevation-surfaces.htm#ESRI_SECTION1_29D3AE... 

I hope that helps!

New Contributor

Hi Lauren,

 Thank you for responding. I'm in Scene but there is still no elevation tab in the properties. Is there some setting to turn it on perhaps?

When I add the layer, it automatically appears under 2D not 3D layers.

Thanks!

Reply
0 Kudos
Esri Regular Contributor

Jonah, At Pro v.2.2, elevation settings got moved from the Map properties dialog box to the Contents pane of the scene. If you tried setting the TIN as the elevation surface, it sounds like you know this already. How did you try to set the TIN as the elevation surface?

This is what I did: added a TIN to a scene in Pro. It went under 2D Layers in the Contents pane (same as it did for you). At the bottom of the Contents pane, under Elevation Surfaces, I right-clicked Ground and clicked Add Elevation Source. Then browsed to the TIN dataset location on disk. Now when you identify TIN locations, the elevation units reported in the status bar next to the x,y coordinates should be the values stored in the TIN. (Whereas if you click somewhere off the TIN, elevation values in the status bar reflect the default ground surface: WorldElevation3D/Terrain3D.)

In the Map Properties dialog box for the scene, you might still need to check your elevation units (on the General tab) to make sure the correct reporting units are being used. Like if your TIN elevations are in meters, this setting should also be meters.

New Contributor

Hi Tim,

 I right-clicked on "Ground", "Add elevation source" and chose a TIN dataset. It adds it in the contents pane but the view shows that it is loading and will continue to do so indefinitely.

The properties doesn't bring up the elevation tab. Am I looking in the right place?

Thanks.

Reply
0 Kudos
Esri Regular Contributor

 Sounds like maybe your system resources are taxed. Maybe Jeremy Wright‌ can give some advice.

Reply
0 Kudos
Esri Regular Contributor

Jonah,

I'll email you directly and you can send me the TIN so I can see if I can repro the problem.

J

New Contributor III

Hi Jeremy,

what was the upshot of this trouble-shooting?   I have the same issue as the OP just trying to follow step 3 of this help page:

Visualizing the Space Time Cube—ArcGIS Pro | Documentation 

Reply
0 Kudos