deleted longitude and latitude fields in webmap table

139
3
05-06-2021 10:29 AM
Labels (2)
LNvoyageuse
New Contributor

I created a feature layer on ArcGIS Online that I wanted to connect to the mobile app Field Maps for data collection. I went on the "data" menu of my feature layer on ArGIS Online to add fields relevant to my research, but I have very stupidly deleted all the pre-existing ones, including longitude and latitude etc.

Now I am left with only the mandatory ones (that I could not delete), which do not include long and lat. When I collect data via Field Maps and I open the table to see the items collected in my feature layer, I see all the points and lines displayed correctly, but I do not see long and lat as attributes since those fields do not exist anymore.

So even if Field Maps collects these data, I do not see them as attributes to every object. Any clue on how to get long and lat to show as attributes in my table?

0 Kudos
3 Replies
RobertBorchert
Frequent Contributor II

Add the Lat and Long fields back in as Double then Calculate Geometry on those fields and add the X,Y coordinates back in. 

LNvoyageuse
New Contributor

Thank you! How would I add them back in? That is my entire conundrum. Your help is greatly appreciated.

0 Kudos
RobertBorchert
Frequent Contributor II

Do you  have access to ArcMap as well as Pro.  It works better in ArcMap.

In Pro add the Feature Class.

Right click on the FC and select Design > Fields

All your fields will pop up.

At the bottom select Click here to Add New Field.

Add you Longitude and Latitude back in as they were named before

Make the Data Type as Double

Save the changes

Open the Attribute Table

Right click on Longitude (or whatever you named it) and select Calculate Geometry.

Using the Target Field Drop down menu you can add Latitude also and just select the correct X or Y 

Choose Coordinate Format and System. 

I prefer doing it in ArcMap however,

0 Kudos