Create Enterprise Geodatabase Error - st_geometry.dll for PostgreSQL and ArcGIS Pro 2.7.1

351
2
Jump to solution
02-25-2021 01:43 PM
Labels (2)
aricraimundo
New Contributor II

I've downloaded st_geometry.dll from My Esri and installed PostgreSQL 12.4 along with PostGIS in a Windows Server 2016 Datacenter. The library was copied to lib folder.

All installations was downloaded from My Esri.

I'm getting the following error when I'm trying to create an Enterprise Geodatabase using ArcGIS Pro 2.7.1.

You must copy the latest ST_GEOMETRY library to the PostgreSQL software location. Refer to the ArcGIS help topics for more details.

I check that this is happening with PostgreSQL 11.9 too.

I believe st_geometry.dll available in My Esri doesn't work with ArcGIS Pro 2.7.1. The st_geometry version for PostgreSQL 11/12 is 11.1.0.2555.

Any clues?

0 Kudos
1 Solution

Accepted Solutions
George_Thompson
Esri Frequent Contributor

If this is a fresh install of PostgreSQL on the Windows machine, you need to make sure that you install the MS Visual Studio version listed here: https://desktop.arcgis.com/en/system-requirements/latest/database-requirements-postgresql.htm

"To use a geodatabase or the ST_Geometry type in PostgreSQL on Windows, you need the latest Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017, and 2019 installed on the PostgreSQL machine. See the latest supported Visual C++ downloads from Microsoft support for more information."

This has bit me more times than I want to admit.......

Once that is installed try the Create / Enable Enterprise Geodatabase tool.

--- George T.

View solution in original post

2 Replies
George_Thompson
Esri Frequent Contributor

If this is a fresh install of PostgreSQL on the Windows machine, you need to make sure that you install the MS Visual Studio version listed here: https://desktop.arcgis.com/en/system-requirements/latest/database-requirements-postgresql.htm

"To use a geodatabase or the ST_Geometry type in PostgreSQL on Windows, you need the latest Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017, and 2019 installed on the PostgreSQL machine. See the latest supported Visual C++ downloads from Microsoft support for more information."

This has bit me more times than I want to admit.......

Once that is installed try the Create / Enable Enterprise Geodatabase tool.

--- George T.

View solution in original post

aricraimundo
New Contributor II

It worked ! Thanks a lot.