Coordinate System is Corrupted in 2.6 Beta2 and 2.6 Release

07-30-2020 02:57 PM
New Contributor

I've been using a project based on ESRI staged data (Naperville Gas) that is modified to point to my organization's instance of ArcGIS Enterprise.  In 2.5.x and 2.6 beta 1, I had not been experiencing any issues creating features. Upon installing 2.6 Release, when I try to perform the same actions as before (creating features), the Create Features pane says there are no editable layers.

Looking at the cause, the Editing Status dialog says that the Elevation Units /Source Vertical Units need to be the same.

Looking at the map properties/Coordinate Systems (2.6 release view), there are 2 copies of the "NAD_1983_HARN_StatePlane_Illinois_East_FIPS_1201" layer.

One is correctly divided into the asset objects

The second looks like this (Gas Utility Network is the name of the UN layer in this project)

For the Z Coordinate Systems Available, there are 2 

So when you look at Transformation there's a problem. It's trying to transform to both Z layers.

The same project file opened in 2.6 Beta 1 (as well as 2.5) have coordinate systems/transformation that look like this

Only 1 instance of NAD_1983...

Only 1 Z Coordinate System layer available

And only 2 lines in Transformation (no errors/only transforming 1 Z layer)

And Create Features offers drawing templates

Additional info: For projects that don't have a Z Coordinate System selected (with only 1 Z layer or no Z layers available), the Transformation does not have errors.

Questions: Why is 2.6 (beta2 and newer) adding a Z coordinate system [NAVD88 (depth) (ftUS)] that is was not visible in 2.5 and 2.6 beta1 for this project?

How do I fix the problem with the extraneous transformation relationship?


After spending some time with support we tried the following:

1. Changing the Current Z layer (in Coordinate Systems) to none did not fix the issue. There were still no editable layers.

2. Examining each drawing layer, the Elevation setting looked like this

2.6.0 Release Version (broken in 2.6.0 beta 2) where none of the layers are editable

2.5.x (up to 2.6.0 beta 1) where the Create Features templates load correctly

The question is why does the Elevation units setting on every drawing layer have the wrong value in 2.6.0 (beta 2 and release)?  Is something not mapped correctly.. or not mapped at all?

3. When at least one of the drawing layers was corrected to be "Data source vertical unit" the Create Features pane populated with templates appropriate to the corrected layer. 

It required a manual correction to existing data. 

0 Kudos
0 Replies