Clip raster freezes Arcgis pro

330
11
11-24-2021 11:43 PM
saidurgamalleswarthota
New Contributor III

I'm using clip rater to clip USA population data with polygon shapefile of USA Counties with the help of a model builder.

If I check the box of "Use Input Features for Clipping Geometry" then Arcgis is freezing for some polygons.

If I uncheck that box, everything is fast and smooth. The operation was successfully completed.

I tried using "if field value is" in the model builder to exclude that specific polygon which is causing acrgis to freeze like "71". But again I'm having the same problem with another polygon like "84". I can't just keep on finding the troublesome polygon like this. Totally there are more than 3000 polygons.

If I "use Extract by mask" it takes too much time to complete the whole process.

Anyone, please tell me what is the problem and how to deal with this.

I have to use "Use Input Features for Clipping Geometry".

 

0 Kudos
11 Replies
saidurgamalleswarthota
New Contributor III

I tried to clip the polygon and the result is more than 11 GB. As you can see the screenshot the clip raster is covering whole pacific ocean from west to east.

saidurgamalleswarthota_0-1638011740649.png

 

Please tell me how to deal with this issue.

0 Kudos
DanPatterson
MVP Esteemed Contributor

You need to set the "extents" in the tools "Environments.  

They wrap around the date line.  Do you need to include the islands off of Alaska?

I suggest that you divide your workflow to use continental US first then Alaska and Hawaii if needed, the file has a lot of nodata area.


... sort of retired...