Cannot configure/activate Illumination parameters for a Global Scene

3766
12
Jump to solution
04-01-2015 07:22 AM
YovavZohar1
Occasional Contributor III

Did anyone succeeded to activate the "Show atmospheric effects" or "Display shadows in 3D" parameters in a Global Scene?

After configuring the Scene properties and clicking OK button, nothing happens and reopening the Scene properties, shows that none of the definitions were saved.

I've tried it on several computers and several geographic locations without any change.

Thanks in advance,

Yovav Z.

Reply
0 Kudos
1 Solution

Accepted Solutions
YovavZohar1
Occasional Contributor III

Hi Prasanta and Jeremy,

Eventually, after fiddling with the issue, Rebecca from ESRI Tech Support has managed to pinpoint the cause for this behavior (applause).

It's a bug that occur only when the OS Time zone is defined as UTC+2 Jerusalem.

other UTC+2 time zones doesn't present similar phenomenon, and this is the workaround for bug - chnging the Time Zone.

The bug still exists in Pro 1.1 Beta.

BUG-000087447: ArcGIS Pro does not recognize Jerusalem time zone, resulting in non-functionality of illumination options for global and local scenes

View solution in original post

Reply
0 Kudos
12 Replies
JeremyWright
Esri Regular Contributor

Yovav,

I just tried on my machine with the 1.0 final build and I was able to change the illumination settings and have them stick...

Is this for EVERY project or just one or two?  For instance if you just click on "New Global Scene.aptx" and then go to this menu and try to change it, can you see it stick?

Regards,

Jeremy W.

Reply
0 Kudos
YovavZohar1
Occasional Contributor III

Hi Jeremy,

I've tried it on several computers (at least 1 as fresh install), and also in new and old Projects and Global Scenes.

All of the above displayed the same behavior - I managed to mark the check-boxes, but after approving the scene properties (Clicking OK button), Illumination parameters were not saved or had been reset automatically.

Regards,

Yovav Z.

Reply
0 Kudos
JeremyWright
Esri Regular Contributor

Yovav,

are you on a non-english locale?

Regards,

Jeremy W.

Reply
0 Kudos
YovavZohar1
Occasional Contributor III

Yes,

but I've tried to change the locale to English USA, with no different results.

Reply
0 Kudos
JeremyWright
Esri Regular Contributor

Yovav,

OK, trying to figure this out.

I've seen some issues when changing these options and an invalid option has been selected on another tab (for instance, add an empty Elevation Surface) - then whatever you changed doesn't take effect, because it was committed with an invalid property change (ugh). 

So if you just

1) hit New Global Scene

2.  Go to elevation properties

3.  turn on shadows, hit OK.

this doesn't take effect?

What if you instead do new blank project, then go to Insert tab and hit New ->Scene?

Reply
0 Kudos
YovavZohar1
Occasional Contributor III

Hi Jeremy,

Thanks again for your time.

I've tried that without any change.

regards,

Yovav Z.

Reply
0 Kudos
YovavZohar1
Occasional Contributor III

Hi Jeremy,

I've also tried it on a new installation of the ArcGIS Pro 1.1 Beta with same results

Regards,

Yovav Z.

Reply
0 Kudos
JeremyWright
Esri Regular Contributor

Yovav,

Sorry, I'm out of my depths here - my team works on the graphics engine, not the UI.  This issue appears to be the UI not functioning as designed.

FYI I've forwarded your information to the team responsible for this UI.  I've asked them to reply here with any suggestions.

Regards,

Jeremy W.

Reply
0 Kudos
YovavZohar1
Occasional Contributor III

Hi Jeremy,

Thanks a lot for the efforts.

I concur that it seems like a UI issue.

Regards,

Yovav Z.

Reply
0 Kudos