ArcPro Topology Error Inspector Table does not refresh

08-07-2019 02:14 PM
New Contributor II

*** UPDATE*** as of 09/2019 below Issue has been logged as a bug. ***

When using Error Inspector in ArcPro 2.3.3, it inconsistently filters errors to map extent in the error table.

It seems that it will only filter results in the  until an attribute table is opened. Once an attribute table is opened the error table will will not refresh and will display only the errors displayed at the time the attribute table was opened. 

This has become an issue when trying to filter by rule later so that I can edit specific types of errors in an extent as a batch. #goingbacktoArcMap

Any ideas? 

Below is a quick run down of the process and screen shots to give an idea. I have tried this with different maps and data and get the same failure to refresh. 

Map Opened.

  1. Open Error Inspector
  2. Validate map on full extent
  3. 1) Filter by Map Extent is Active. 2) *2000 errors exist in the full map extent.
    1. Currently I am only worried about dangles along the quad border. I zoom into a location I want to inspect. 1) Filter by Map extent is active. 2) 6 Errors in map extent.
  4.  Open Attribute Table.
    1. Zoom to full Extent. 1) Filter by map extent still active 2) Only 6 errors are listed 3) even after refreshing the table.
    2. If I zoom to a new location the table still does not refresh and will not properly populate this table until I have restarted the map project. It will function after restarting the program until I open an attribute table. After that the table fails to refresh. 
0 Kudos
2 Replies
Esri Regular Contributor

Hi Rachel,

The image in step 7 shows the map extent filter is off. What steps lead to that being turned off?

0 Kudos
New Contributor II

Hello Sean, 

I turned the map extent filter off in the screen shot to show that even without the filter only 6 errors display when there should be 2000+.

A bit after posting this, I worked with ESRI Tech support on this for a couple weeks and it was reproducible on their end with their data. Unfortunately, it is a bug.

In addition, it doe not appear ArcPro allows me to symbolize topological errors by type. I have decided to return to ArcMap to address this type work. 

0 Kudos