ArcPro 2.7.3 won't open ECW files

466
11
04-15-2021 08:48 PM
Ozplanman
New Contributor II

I've recently upgraded to ArcPro 2.7.3 and the software gives me "unsupported data type' when I try toopen an ECW file.  I thought this was fixed after version 2.1 or such?

Anyone know why?

0 Kudos
11 Replies
DanPatterson
MVP Esteemed Contributor

It is on the list

Raster file formats—ArcGIS Pro | Documentation

What is the last version that you used that you could open them?

There are a number of outstanding bugs, for example...

BUG-000123365: Some Enhanced Compression Wavelet (ECW) files do not.. (esri.com)

There are more... just sort newest to oldest

Esri Support Search-Results


... sort of retired...
Ozplanman
New Contributor II

Hi Dan, yes I checked that list.  It seems random.  I have ArcPro on my laptop at home and am sure it opens them there but this new install and upgrade to 2.7.3 doesn't want to open them.  This is an ecw that I have used for years and which opens fine in ArcMap and everything else.  Another undocumented enhancement I guess.

0 Kudos
Tim_McGinnes
Occasional Contributor III

I am running 2.7.3 here and my ECW files are opening ok. Do you have any other ones you can test with? Is it happening to all of them? Can you right click on it in the Catalog pane and choose Properties, if so what does it say? 

0 Kudos
Ozplanman
New Contributor II

Hi Tim, no properties showing.  As I mentioned above, it is an ecw I have used for years without issues...Cheers.

0 Kudos
Tim_McGinnes
Occasional Contributor III

I have attached a small test ecw file that you can use to confirm that your Pro install can actually open and display them.

Unfortunately it does sound like an issue with that particular ecw file. Your best bet may be to open it on your laptop, get the file properties and contact Esri support for assistance.

0 Kudos
Ozplanman
New Contributor II

Thanks Tim, appreciate the effort, but that's not necessary. I have the file open in ArcMap desktop, another of our staff have it open in ArcMap, it's not the file, it's just ArcPro being painful. 🙂 

0 Kudos
DanPatterson
MVP Esteemed Contributor

Great news! ..... sort of...

It opens brilliantly in ArcGIS Pro 2.8 Beta 1 (cool image BTW).

So if it opens in pre 2.7.3 and not in 2.7.3...

  • Tech Support it,
  • apply for the 2.8 Beta program,
  • roll back to 2.7.2 or
  • wait.

It just asked me to create statistics when I zipped up for you as an attachment if you want to compare to stats you may already have.

 


... sort of retired...
0 Kudos
DrVSSKiran
Occasional Contributor II

Hi Ozplaman, here is a quick turnaround for your problem. Open ECW file in ArcMap and save it map document file and now import map document file in ArcGIS Pro and see whether ECW reflects perfectly or not. Thanks.

0 Kudos
Ozplanman
New Contributor II

Hi all,

Just thought I'd throw a quick resolution message here.  Seems that ArcMap desktop and ArcPro don't always play nice and when you add other packages in there it becomes more fun.  The ECW file that I have used for ages and which was the primary one which threw the error, has had an AUX and an XML file created for it by one package or other and ArcPro didn't like them.  I deleted them and it opened it happily.  I found this out by opening the original ECW in ERDAS Imagine and exporting it to a different ECW file in another folder.  This new ECW of the same image, opened fine in ArcPro.

So, I should have realised that, given the pain we've had with AUX files in the past, that this was a likely issue.  Blow away the unnecessary files which will be regenerated and it may work.  Of course, next time I try and open it in ArcMap Desktop it will probably have a dummy spit!

Cheers all!

0 Kudos