ArcGIS Pro Project Read Only Behaviour

07-09-2020 12:01 PM
Occasional Contributor

On a virtual server we have a bunch of projects saved. These project each relate to a published portal map image layer that we consume as a map service in our applications.

Recently (as in the last month) one of these projects started to only open in read only mode which is mildly inconvenient if you want to make changes to the published service. Originally I assumed someone was accessing it. However, because its a locked down VM it was pretty easy to ask the people who have access to the VM if they have it open. They didn't have it open. I also tried turning off the service that accesses it assuming that may be causing it for some off reason, it wasn't. Its only one project on a drive with a whole bunch of them, but I'm just worried it will start happening to more of them.

I've also tried just opening the project and saving it as a different name (creating a new project). This brand new one now only opens in read only mode as well. 

After reading through some articles about similar instances I've done about everything I can do.So I'm at a loss for trouble shooting, hopefully someone else has seen this behavior. 

Service was published out of pro 2.5.1 which is still the current version of pro used on that VM.

Tags (1)
0 Kudos
2 Replies
Esri Frequent Contributor

One thing I saw related to this on the Esri internals is in the VM to "share" the folder where all your ArcGIS Pro projects are stored to the project team.  Another user had "partial permissions" to the folder set so share with full read/write permissions to the users.  Is the "read-only" behavior gone?

0 Kudos
Occasional Contributor

Hi Robert, thanks for the reply. There are only 3 people who have access to the specific VM and its local drive that projects are being published out. I did go check the drive and folder permissions and all three of us have "full control" over them. I tried to bump the permissions by changing them and changing them back followed by a full reboot of the VM, but to no avail. 

I just find it curious its only 1 project (so far). I don't really think its important enough to submit a ticket for as its probably just some odd local VM setting somewhere. But it would be nice to trace the cause if possible.