ArcGIS Pro not opening Folders in Favorites in the Catalog View

1763
24
02-01-2018 08:58 AM
MikeW
by
New Contributor III

All I want to do is to use the ArcPro Catalog View in the same way that I used the Catalog window in ArcMap.  Under my Favorites tab I added two folders both of which have subfolders with shapefiles and geodatabases in them.  However, Pro refuses to allow any browsing beyond the folder item I added.  My issue is somewhat analogous to this question: ArcGIS Pro does not recognize a folder but should be simpler.  According to this page: Project favorites—ArcGIS Pro | ArcGIS Desktop  it should provide me access to all the subfolders and items in the Favorite folders.  What am I missing here?

Tags (2)
0 Kudos
24 Replies
MikeW
by
New Contributor III

Yup, that's why I'm trying to get out in front of the shift so that I can hammer out these annoyances now.

KoryKramer
Community Moderator

Sorry to jump in late here, Mike.  I agree with Dan Patterson‌ - ArcGIS Pro is not ArcMap.  Some things are done differently.  If you have 5 minutes to save yourself any further frustration, take a look at ArcGIS Pro Tips: This Might Just Be Your Favorite Tip Ever | ArcGIS Blog to help get a better grasp of how Favorites work.

And for a more general overview of the Catalog Pane vs. Catalog View, you might like Dude, where’s my Catalog? | ArcGIS Blog 

For ArcMap users—ArcGIS Pro | ArcGIS Desktop should be helpful.

And the ArcGIS Pro quick-start tutorials—ArcGIS Pro | ArcGIS Desktop shouldn't be snubbed as they are a very efficient way to get a quick feel of working with Pro.

Hope these help!

MikeW
by
New Contributor III

Very very helpful links.  Will pass these along to colleagues.  Thanks, Kory.

deleted-user-83hyT1o4YRnn
New Contributor

I have the same problem with my portal content. When i want open one folder from my portal content I can`t. It look empty". Also sometimes i do not see my layers in databases (from 25 layers i see just 3 etc.)

Refreshing do not help.

Maybe someone knows why?

0 Kudos
ChrisMorse1
New Contributor

I have a similar issue, except that it is in both the Catalog Pane and Catalog View. When browsing a directory, I can see my file geodatabase. This file geodatabase is new and contains 1 feature class which contains 3 features. While browsing in the Catalog View or the Project tab of the Catalog Pane, I get an error when I try to expand the geodatabase to explore its contents. The error is: "The parameter is incorrect".

When I add the same folder to the Favorites tab in the pane and then browse to the geodatabase within it, it expands just fine and I can view the contents. The feature class can be added to the map through drag and drop or through Add Data. While in the map, the feature class displays and labels just fine. So it doesn't seem to be a corrupt database.

So why does expanding the geodatabase to browse its contents only work in the Favorites tab of the Catalog Pane and in the Add Data window?

Note: Pro Version 2.4.2

0 Kudos