ArcGIS Pro Model with many parameters takes forever to validate each parameter. Anyone else?

242
3
11-22-2021 09:03 AM
David_Brooks
MVP Regular Contributor

Does anyone else find that if they have have a model builder tool with many parameters, inputting each parameter in the tool dialogue can take forever?

I have a few tools with 18-20 parameters in them, (some of these are input features, some are field calculate and some are reclassify).

These have been migrated from ArcMap, where they ran smoothly. However, i find that Pro runs a validation on every parameter you populate, which takes around 5-10 seconds. So to fill in every parameter can take a couple of minutes each time. This is becoming tedious beyond belief. BUT what makes it worse, is that if you try and fill in a parameter before the previous one has validated, it resets your input. So you can find yourself running a tool without fully populating the parameters by mistake.

Please tell me others have this same gripe, or have a workaround? My solution will be to convert to python, although im assuming the parameter validation will still occur?


David
..Maps with no limits..
0 Kudos
3 Replies
ABishop
Regular Contributor II

Hello,

Is there a reason you have to have them set with parameters?

Amanda Bishop, GISP
0 Kudos
Robert_LeClair
Esri Frequent Contributor

As the model worked properly in ArcMap and is being used in ArcGIS Pro, did you run the Analyze Tools for Pro GP tool to see if there were any issues that would impact the model?  

DanPatterson
MVP Esteemed Contributor

converting to a tool in a toolbox, should help.  The custom and python tools allow for parameter validation and setting defaults for tool parameters.  My preference is for the custom python tools since the parameter validation can be kept separate from the actual functional code.  The new *.aptx format will improve on this as it evolves


... sort of retired...