ArcGIS Pro: Label Settings Window Closes Before I'm Finished

470
20
06-06-2019 02:26 PM
Highlighted
New Contributor II

A coworker and I have experienced a possible bug regarding labeling settings in ArcGIS Pro. We are both on version 2.3.2 and run Windows 10 and 7 respectively. 

It manifests itself as follows:

1. Right click on a layer in the Contents pane and click on Labeling Properties....

2. Go to the Position tab (note: there is no Apply button at the bottom of this window). Change any setting. 

3. As soon as a single setting is changed, the change is applied, the Labeling Properties window closes, and is replaced with a window that says "Select a feature layer in the Contents pane".

This is really annoying because I cannot change multiple position settings at a time. I have to go to contents and get the Labeling Properties window open again, make a change, watch it close, and do it all over again to make a third change, and so on. 

Is anybody else experiencing this?

Tags (3)
20 Replies
Highlighted
Esri Contributor

Hi Ryan,

I haven't seen this happen before.  Do you only see the issue when you're working in layout view?  What happens if you access the labeling properties from Map view?

I'll try to reproduce it as well.

Thanks

Wendy

Reply
0 Kudos
Highlighted
New Contributor II

It does not happen in map view. 

Reply
0 Kudos
Highlighted
New Contributor III

Hi,

We see this pretty much every time we try and edit labelling in the layout view. When we access the properties from map view they usually stay open. However, I usually want to edit the labelling in layout view!

We are using ArcGIS Pro 2.3.3 but this has been occuring since 2.3.

Thanks,

Blythe

Reply
0 Kudos
Highlighted
Esri Contributor

Hi Ryan and Blythe,

I've installed Pro 2.3.2 on my win10 machine and I'm not able to repro the issue.

Is it possible to send a short video of the workflow?  I'm must be missing something in my steps.

When I share workflows with my offsite colleagues I like to use LICECap.  it's quick and easy to use if you don't have another option.  Easy to find through google.

I'm also going to loop in Ciara who also works in this area.

.Ciara Rowland-Simms

thanks

Wendy

Highlighted
New Contributor II

Wendy,

See a video attached.

Thanks

- Ryan Keeney

Highlighted
New Contributor III

Aside from having the labelling options (and everything else) docked on the right hand side of the screen, this is exactly what we see.

Reply
0 Kudos
Highlighted
New Contributor II

Blythe,

I just tested this out and I concur. It happens only in a layout, not in a map. 

- Ryan

Reply
0 Kudos
Highlighted
Esri Contributor

Hi Ryan and Blythe,

What I'm seeing in the video is that the selection of the layer is being completely lost when you change that labeling property.  See how the three contextual Feature Layer tabs (Appearance, Labeling, Data) are lost at the top when the labeling pane goes grey?  That's what I'm looking at.

A couple things to try

      - undock the label class pane and put it over on the other side of the screen

      - close out the other layout, map and catalog views so there is only the one layout open

do either one of those steps change anything?

Ciara Rowland-Simms‌ I've spoken with Tom Bole‌ about this and he's going to continue on with it.

Thanks all!

Wendy

Highlighted
New Contributor III

Hi Wendy and Tom,

My collegue and I have both tried your suggestions with no changes.

Blythe.

Reply
0 Kudos