ArcGIS Pro export to PDF not preserving layer transparency?

527
8
09-11-2019 04:55 PM
Highlighted
New Contributor III

I'm working on a map in ArcGIS Pro 2.4.1 in which I have a layer with 50% transparency. Here you can see what the color of the polygon is and how it appears in layout view with the transparency:

When I export to PDF, I get this:

Same results with JPEG and PNG.

Question: Anyone know why the transparency isn't being preserved during the export to PDF? Thanks for any help you can provide!

Reply
0 Kudos
8 Replies
Highlighted
Esri Regular Contributor

andy,

It actually looks like the poly is still transparent, but

a) In your exported PDF (I assume at higher DPI than display) you're getting a different LOD of the hillshade in the basemap, which doesn't actually include the hillshade.  Topo and other basemaps do this content change and higher LODs which trips us up all the time :/.  

b)  Your layout may be set to be CMYK, which means the colors would appear darker/muddier due to different gamut.  you can check this in Layout properties dialog.

Jeremy W.

Reply
0 Kudos
Highlighted
New Contributor III

Afternoon Andy, 


Did you ever get this figured out? I too am having Transparency issues during Export to PDF.

This is my map in Pro, with Transparency working:

Transparency works in Pro

Here is the export to PDF, with Transparency not working

Transparency not exported Properly

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Not sure what is going on in your case - can you send this to Esri support so we can get a ticket started?

Reply
0 Kudos
Highlighted
New Contributor III

Will do Jeremy, 

I was just going through the various output formats to see if any of them will export transparent, but so far I am not having luck. Our organization has Premium Support, so I will get a ticket started.

Thanks,

Matt

Highlighted
New Contributor III

Hey Matt Reeves,

I'm not encountering the problem anymore. What version of Pro are you on? I just upgraded to 2.5 and tried to replicate the issue, but the transparency was honored. Exported a map to PDF, JPG and PNG with multiple layers with transparencies and they all came across in the export. Not sure if this is a glitch or if the software is actually working now.....regardless, thanks for sending in a support ticket!

Jeremy Wright, have you been able to replicate the error? 

Highlighted
Esri Regular Contributor

No, that's why I was curious as to other factors.  This type of issue it's better to do troubleshooting interactively with Esri Support - it's not really conducive to forum discussion.

Highlighted
New Contributor III

Thank you for responding Andy,
I too am on 2.5. My Transparency is being respected for a lower level layer (a DEM draped on a hillshade). However, a higher up layer is coming through solid. I've put in a request for an ESRI ticket, so I will report back when I've worked with them.

-Matt

Highlighted
New Contributor

Exporting a .lyr file with transparency was not working for me either. I instead downloaded the geodatabase that included the feature to bypass using the .lyr file. I set my transparency and exported with no issues. Appears the .lyr file is the root of the issue. 

I am using ArcGIS Pro 2.5 w/o the latest patch

Reply
0 Kudos