ArcGIS Pro Export to Layout PDF results in a PDF with 1kb

1032
5
08-17-2020 01:32 PM
AnthonyVazquez
New Contributor

I tried exporting a map layout to PDF in ArcGIS Pro. The result was about 6,000 kb and opened perfectly fine in Adobe Acrobat Pro.

I noticed a small map mistake, closed out Adobe, fixed the map mistake in ArcGIS Pro, and I went to export the layout to PDF with the same name to overwrite the old one I had exported. This time the export was almost instantaneous but, when I went to the folder with the PDF, the PDF said it had only 1 kb and opening the PDF resulted in Adobe showing the following:

Adobe Message Error

I tried different ways of fixing this but I have been unsuccessful so I thought it might be the project I was working on. I tried Export Layout to PDF from three different projects saved in different locations and all of their results are 1kb damaged PDFs.

My settings for all of the exports:

File: PDF

Name: path to a folder on my local computer

Clip to Graphics Extent: Unchecked

Output as Image: Unchecked

Quality: Max

Compress Vector Graphics: Unchecked

Vector Resolution: 96 DPI

Raster Resample: Best

Embed Fonts: Checked

Covert Character Symbols to Polygon: Unchecked

Export Georeference Info: Checked

Layers and Attributes: PDF Layers Only

Simulate Overprint: Unchecked

I'm trying to see if this is a current problem others are experiencing in ArcGIS Pro or if this might be an issue where I need to uninstall and re-install ArcGIS Pro. Thank you for any help on this matter.

TLDR: Export to PDF was working until I tried to overwrite a PDF with a new one of the same name. Now all my Layout Export PDFs result in 1kb PDFs and won't open due to being damaged.

0 Kudos
5 Replies
NikolasDingus
Esri Contributor

Hi Anthony, a couple quick questions regarding what's going on here:

1. Are we able to successfully open the PDF in any other application, such as a web browser? 

2. What version of Pro are we working with? 

3. Do we have any TIFF images in the layout? In Support here I've seen some issues with TIFFs in the layout, so I am curious if this may be what it comes down to. If there is a TIFF in the layout, change it to a JPEG or PNG and see if the export works successfully. 

0 Kudos
AnthonyVazquez
New Contributor

Hi Nikolas,

1. No, opening the PDF in Google Chrome or Firefox does not work either. I'd say probably because the PDF file created from the export has only 1kb.

2. I'm using ArcGIS Pro 2.6.0

3. I do not have any TIFF images in either the original map layout or the map layouts I tested.

The workaround I'm using right now is exporting the maps to TIFF and converting the TIFF files to PDF but that takes much longer than just exporting to PDF. Doing that has at least helped me with knowing that the export layout is working for certain file types but PDF is giving me the only problem so far.

0 Kudos
TomBole
Esri Regular Contributor

Hi Anthony, 

I'm not aware of any issues that would result in corrupt PDFs other than the TIFF issue Nicholas referenced.

Can you contact Esri Support? They are better equipped to handle troubleshooting steps and gather bug data. They can be contacted at https://support.esri.com/en/contact-tech-support.

Thanks, 

Tom

CarlMorrison
New Contributor III

Hi Anthony,

I was having a very similar issue and realized that our company logo, used in our layout template, is a tiff image.  Changed it to a png image and everything works as it should.

Carl

RyanBarber1
New Contributor II

Carl,

Thanks, I just had the same issue with my company logo!

-Ryan

0 Kudos