ArcGIS Pro does not recognize a folder

14471
42
11-06-2014 01:50 PM
AaronWeier2
New Contributor II

Has anyone else had an issue with ArcGIS pro not recognizing folders? The main project folder we use does not get listed when connecting to the drive where all of our project folders are. I find this terribly frustrating! Plus Pro crashes a lot for me and I haven't even done anything yet!

42 Replies
RoyceSimpson
Regular Contributor

I'm not sure why it took me so long to try this "attrib -s" method but that seems to have done the trick.  Now, we just need Pro to ignore that attribute since we seem to have the scattered all over our file system.

x (x)
KristofferWaage_Beck2
New Contributor III

Yes, and notice 2 things

1. All settings on the folder will be shown with the command:

'attrib [folder name]'

2. It seems to be possible to assign/remove the values from all subfolders in one command line using the /S option.

0 Kudos
RoyceSimpson
Regular Contributor

The problem seems to be with those .adf files.  It would be one thing if those files were just legacy files from the old coverage days, which I have the authority to delete, move, etc... but the reality is... on our corporate network drive, there are dozens and dozens of folders that have nothing to do with arcinfo... coverages or otherwise... and sometimes, there are other files with that .adf extension... files that we in GIS do not control... if that file is buried 10 folders deep, the entire path with be hidden in Pro right down to the drive letter level.  This means that for example, if we have a folder called "g:\aaa" and in that folder is a "gis" folder and a sibling folder called "notgis"... and in that "notgis" folder is a .adf file, I won't be able to see the root "aaa" folder.  It's a real deal breaker for us and is the one outstanding Pro issue that prevents us from deployment.  Granted, you can simply type in the folder path by hand as in "g:\aaa\gis" and Pro will find it and assuming those adf files are not down that path, you'll then see the folders from then on out, but we can't deploy org wide with that sort of nonsense.

Double boo on esri for not figuring this out by now.

x (x)
0 Kudos
KoryKramer
Community Moderator

Hi Royce,

I've been in touch with our development team responsible for this area of ArcGIS Pro and they are not able to reproduce the behavior you're describing.  

Would you be able to open a technical support case to further investigate the issue?  It would be a good channel to get us an example folder/file structure that causes this problem.

Thank you!

RoyceSimpson
Regular Contributor

Hi Kory, I'll put in a case ASAP. 

Thanks. -Royce

x (x)
0 Kudos
RichardDaniels
Regular Contributor

Kory,

They must not be trying that hard ☺; just use the attrib command in DOS and change the a folder attribute to System. After that the folder will not appear in Pro the next time you try to navigate to it with Add Data. If Pro is open you have to hit F5 in the Add Data Window to reread the folder structure from disk.

The issue with the .gen files, folders with index documents (created by Pro) not appearing, etc. is documented in this thread. It appears Pro is using a ‘magic’ list of files/file extensions to determine if it will display a folder (and subfolders) in Add Data. As I recall there used to be a setting in Advanced Settings (in 32 bit Desktop) where you could control some of this behavior. The intent in the past was to reduce the number of folders shown to the user to ‘just’ folders with valid GIS data –which is why Add Data is rarely identical to a Windows File Explorer view.

The primary problem is that for some file extensions, entire folder trees are not being displayed.

For example, if I have this structure:

.\ document

.\ document\projects

.\ document\projects\mydata

.\ document\projects\mydata\index

.\ document\projects\mydata\index\segments.gen

When the .gen file is encountered the index folder is not displayed in Add Data, so I just see the following:

.\ document

.\ document\projects

.\ document\projects\mydata

This may be the intended behavior, if so the list of reserved folder and file names needs to be documented and easily found in ArcGIS Pro help.

Sincerely,

Richard Daniels

GIS Product Support Coordinator & CAFM/IRIS Support

ITD, WSDOT

0 Kudos
RichardDaniels
Regular Contributor

One of our end users resolved their 'folders not displaying' issue by reinstalling their Microsoft Windows 10 OS Build 1709. After the reinstallation of the OS and reinstall of ArcGIS Pro the folders were visible again.

This is a WAG, but I think Windows Update is setting the S attributed during the Windows OS upgrade (i.e., for Build 1709) on user profiles and files. If the upgrade does not complete without error or the system is not rebooted, the next time a user logs in the OS will have 'delayed' reboots. Thus when you start working the attributes on your files may not have been reset to their pre-upgrade settings (see https://answers.microsoft.com/en-us/windows/forum/windows8_1-files/windows-10-file-attributes/862c70...).

This is of potential concern since with Windows 10 we can expect a major OS upgrade every 4 to 6 months, in the past it was something that you had to deal with once every two or three years.

Rich

0 Kudos
LanceKirby2
Occasional Contributor

The workaround is: first add a connection to the relative path of the folder that contains all of the seemingly invisible folders. For instance, I wanted this subfolder to show up G:\toto\GIS\MWFIV_4States. Instead of adding a connection too G:\toto\\GIS I added a connection too \\toto\. Then I simply connected to "GIS" and added it to my favorites.

CathyWilson2
New Contributor III

It seems to me that when I'm connected to a subfolder, Pro won't show the parent folder. Maybe it thinks I'm already connected to that folder. The workaround that Lance Kirby offers works like a charm! Just connect to the parent's parent folder, then you an navigate to it in the Catalog pane.

DonnaTippett
New Contributor

I clicked on my folder properties. I unchecked read only and clicked the "Advanced" button and the checked "allow to index".  Saved properties, refreshed and the folder and shape files were visible.

0 Kudos