ArcGIS Pro Crashes when editing edges with a WMS layer in the map

141
9
11-08-2019 05:21 AM
Highlighted
New Contributor III

I am experiencing constant crashes in ArcGIS Pro, when I am zooming in the map while editing edges. It only occurs when i have activated Map Topology, and when there is a WMS layer in the map. 

The steps for reproducing the crash are: 

  1. Open ArcGIS Pro 2.4
  2. Add any polygon featureclass
  3. Add WMS service http://kort.aws.dk/geoserver/aws4_wms/ows?SERVICE=WMS&
  4. Activate Map Topology
  5. Activate vertice editing, and switch from feature editing to edges editing 
  6. Try to zoom  
  7. CRASH!!!!

I would love to know what is going on here, or at least if others are experiencing the same

Cheers, 

Morten

Reply
0 Kudos
9 Replies
Highlighted
Esri Frequent Contributor

I would recommend opening a technical support case so that they can investigate since it seems to be easy to reproduce.

Have you submitted your crash reports?

--- George T.
Highlighted
New Contributor III

I have submitted several crash reports. I also opened a case with the local vendor (Geoinfo in Denmark), but I would love a direct line to Esri's technical support in this case. 

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Ok, that is good to know. Your distributor will work with the Esri US tech side, if needed.

--- George T.
Highlighted
Esri Notable Contributor

Hi Morten - I apologize that you're experiencing a crash.

I was able to find the error report that you submitted (thank you for including a valid email address), and I pinged the development team with the detailed repro steps that you provided in the original comment.  Now with those steps they'll take another look and see if they can figure out what is happening.  We'll be in touch if we need more info.

Thank you.

Highlighted
New Contributor III

Thanks Kory, 

I have tried to reproduce the error with some random wms-layers that I found with a simple google search. All the examples made ArcGIS Pro crash in the described way. 

Cheers 🙂 

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Morten,

I tested the workflow you provided and could reproduce a crash in 2.4.2 but not in 2.5, which is not released yet, but coming soon. Thanks for reporting it to us. For what it's worth, here is the workflow with no crash in 2.5:

Thank you,

Scott

Highlighted
New Contributor III

Hi Scott, 

That is great news. Being greedy; is there any chance of a bug fix for 2.4 before the release of 2.5? 

Cheers, 

Morten 

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Morten,

We will evaluate it further. If I have any updates, I'll let you know.

Thanks,

Scott

Reply
0 Kudos
Highlighted
New Contributor III

Hi Scott,

That's awesome. Have a great weekend!

Cheers,

Morten