ArcGIS Pro crashes when add field, calculate geometry, table to excel

1559
8
01-28-2023 01:40 AM
Lots
by
New Contributor

Hi everyone!

I'm using (trying to) ArcGIS PRO 3.0.3. at work and I run into various issues with the most basic things right now. Hope somebody ca help me out here!

 

1) I have a named user license, advanced role, and some esri extensions activated. However, I cannot check the option for authorize arcgis pro to work offline as it is greyed-out (I'm logged in via arcgis online).

2) I can't run some tools e.g. table to excel. I installed both Microsoft .NET 6 Desktop Runtime – Windows x64 Installer, along with the Microsoft Access Database Engine 2016 Redistributable 64-bit driver for Excel but still no progress here.

 

3) The most basic tools cause arcgis pro to crash - I can't add a field in the attribute table via the button (but it does work when I run it via the tools). I can't calculate geometry neither by click nor by the toolbox. No matter what I do - it keeps crashing.

Does somebody has some hints or ideas? Would be so glad!

 

Cheers and thanks in advance!

 

0 Kudos
8 Replies
DanPatterson
MVP Esteemed Contributor

You may need a clean restart of Pro and reinstall.  It has many possible solutions but the procedure outlined here should clean the slate to begin again

Problem: ArcGIS Pro freezes on the initializing screen before the Sign In dialog box displays (esri....


... sort of retired...
0 Kudos
julian_svcs
Occasional Contributor

1) This may be disabled in your ArcGIS Online. If you have permission, go to Organization --> Licenses --> Add-on license and make sure "Prevent memebers from taking ArcGIS Pro offline" is not switched on:

julian_svcs_0-1674951415236.png

 

2) My tool also seemed to give some sort of issue. It ran for ever (eventually forces a stop) but the actual xlsx file was created.

3) I am not able to reproduce this. What field name and type are you creating? I am able to add fields and calculate geometries. If you could give some more context around this to try and replicate the issue.

Thanks.

0 Kudos
Lots
by
New Contributor

Nobody an idea? 😞

0 Kudos
Robert_LeClair
Esri Notable Contributor

Hi Lots - 

For your listed items, here are my thoughts:

1. Julian (above) may be on to something about your ArcGIS Online Administrator not allowing this capability.  I'd check in with them to see if this is what's causing it.
2.  For the Table to Excel GP issue, here are two resources I'd recommend researching a bit.

Problem: Unable to export an attribute table to an Excel file in ArcGIS Pro (esri.com)

Work with Microsoft Excel files in ArcGIS Pro—ArcGIS Pro | Documentation

3.  When I see strange things like this, I rename the ESRI folder to ESRI old in these directories and then repeat the workflow.  

C:/Users/<your_user_profile>/appdata/local and C:/Users/<your_user_profile>/appdata/roaming

0 Kudos
robk
by
New Contributor

I'm having similar pains with Pro 3.0.3 but mine will crash and/or map screen turn black and hang up, totally randomly, even when I'm not even doing anything.  I've tried repair and clean install, but I still have the issues.  Doesn't seem to matter what layers or basemaps I have loaded.  I haven't been able to find any patterns to the issue.

0 Kudos
Robert_LeClair
Esri Notable Contributor

Have you renamed the ESRI folders in C:/Users/<your_user_profile>/appdata/local and C:/Users/<your_user_profile>/appdata/roaming to ESRI_OLD yet?  This sometimes resolves random crashes, etc.  

0 Kudos
robk
by
New Contributor

Strange solution but it seems to have helped some.  I am now get random hangups with the spinning circle of doom for anywhere from 5 minutes to Task Manager - End Task, but no random crashes so far.  Brand new to Pro, trying to modernize from Desktop, but so far I am not impressed.

0 Kudos
Robert_LeClair
Esri Notable Contributor

Robk - we're getting there.  I've worked with ArcGIS Pro for 5+ years now and do not have the random issues you've described.  There can be many reasons why you see the strangeness here.  A couple things I would try:

See if you PC can run ArcGIS Pro - it requires a minimal hardware/software configuration.
Update your video card drivers regularly
Use the techniques in this Esri Community post to troubleshoot issues

I'm certain we can resolve this issue.