ArcGIS Pro: ArcGIS Pro fails to work with excel files (*.xlsx),

625
9
Jump to solution
02-07-2020 12:19 PM
JamalNUMAN
Esteemed Contributor

ArcGIS Pro: ArcGIS Pro fails to work with excel files (*.xlsx),

 

ArcGIS Pro fails to work with excel files (*.xlsx) and ends up with the error “required Microsoft office is not installed”

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
1 Solution

Accepted Solutions
KoryKramer
Community Moderator

Note that Pro 2.4 requires the 32-bit driver (and as provided in that link, can be installed silently even with 64-bit MS products).  And Pro 2.5 can use either the 32-bit or 64-bit version of the driver, in which case the help indicates to install the version that matched your MS products.

Work with Microsoft Excel files in ArcGIS Pro—Excel | Documentation 

Worth repeating:

Pro 2.4 requires the 32-bit version.

Pro 2.5 can use either...

View solution in original post

9 Replies
PanGIS
by
Regular Contributor
JamalNUMAN
Esteemed Contributor

Unfortunate, it never works either way.

Has it ever worked with you?

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
JoshuaBixby
MVP Esteemed Contributor

If you already have 32-bit Office 2016 installed, you will need to use the 2013 64-bit Access installer.  You can't mix and match 32- and 64-bit components of the same Office version.

JamalNUMAN
Esteemed Contributor

It has never worked in my machine either way as it appears in the screenshots above.

What could be the issue here?

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
KoryKramer
Community Moderator

From the documentation that Pan gis‌ provided as the original response:

So, if you're running ArcGIS Pro 2.5, the doc alone is the correct answer as 2.5 can use either the 32-bit or the 64-bit driver.  If you were running ArcGIS Pro 2.4, the current (2.5) doc is misleading... we're working to get that updated.  That is what I was conveying in my response below.

Jamal NUMAN‌ it would be helpful if there is an answer on this thread that worked for you to mark something as correct.

Cheers

JamalNUMAN
Esteemed Contributor

I tested everything from scratch and found out that the error will never pops up in case Pro 2.5 and Office 2019 are installed in Windows 10.

 

If Pro 2.5 is installed without Office 2019, the issue will persist to exist

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
JoeBorgione
MVP Esteemed Contributor
KoryKramer
Community Moderator

Note that Pro 2.4 requires the 32-bit driver (and as provided in that link, can be installed silently even with 64-bit MS products).  And Pro 2.5 can use either the 32-bit or 64-bit version of the driver, in which case the help indicates to install the version that matched your MS products.

Work with Microsoft Excel files in ArcGIS Pro—Excel | Documentation 

Worth repeating:

Pro 2.4 requires the 32-bit version.

Pro 2.5 can use either...

View solution in original post

lubnajarara_ah
New Contributor III

Jamal NUMAN

I tried pro 2.5 and work fine with no issues

Lubna