ArcGIS Pro 2.7.2: Why is saving a project as aprx file taking much of time (experiencing delay) in 2.7.2?

227
4
04-11-2021 04:58 AM
Labels (1)
JamalNUMAN
Esteemed Contributor

ArcGIS Pro 2.7.2: Why is saving a project as aprx file taking much of time (experiencing delay) in 2.7.2?

 

I observed that saving a project as aprx file is taking much of time in 2.7.2. Has anyone experienced this issue in 2.7.2?

 

Clip_681.jpg

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
0 Kudos
4 Replies
DanPatterson
MVP Honored Contributor

Not me, saves really fast.  Mind you I keep my projects really trim, only keeping data etcetera that I really need at the time, and I work with locally stored data.


... sort of retired...
curtvprice
MVP Esteemed Contributor

My only suggestion is check to see if your geoprocessing history is getting huge, that can grow your aprx pretty big if you run a lot of tools.

LindsayRaabe_FPCWA
Occasional Contributor III

Yep - I am having the same problem since upgrading when I save a project for the first time (i.e. start with blank template, add a map, add data and Save). Once saved, any further saves happen at a speed I would call "normal" (i.e. a couple/few seconds). I've been on with tech support and the current state of affairs is "waiting"...... I have a new laptop on the way (current one is dodge) and will see what happens when I get it. If it continues to be a problem with the clean install, I will reopen the tech support case. 

I'm using a different laptop at present and just did a test save and it still took 30 odd seconds to save (blank template - insert new map - add 2 simple layers - save) and that was after it threw an "Unspecified Error" as well. Definitely seems to be something not quite right with this version in my experience. 

A colleague had similar issues with a previous version of Pro (2.7.1) and the resolution (after discussing with ESRI support) was upgrading to 2.7.2 and now it works as expected. I was fine on 2.7.1 and now have issues with 2.7.2. 

The GIS guy (not the IT guy)
Robert_LeClair
Esri Frequent Contributor

Jamal - a few things.

1.  Bring up ArcGIS Diagnostic Monitor to see "where" the delay is occurring in the software.  You can pull this up by clicking CTRL-ALT-M

2.  In the internals, a customer was seeing the same thing and did a few restarts of his PC but performed a system clean of the PC and the save issues disappeared.  It did not say specifically what he did though.

3.  Do a complete (clean) uninstall of ArcGIS Pro 2.7 and a clean install of ArcGIS Pro 2.7.  Test the save workflows.  Then upgrade sequentially to 2.7.1 - perform the save operations.  What is the result?  Upgrade to 2.7.2 - perform save operations.  What is the result?

4.  Are you saving your *.aprx to a local drive or a network drive?

5.  Rename the ESRI folder in your user profile to ESRI_OLD - both in local and roaming.

Let us know how it goes as I'm not seeing this behavior on my ArcGIS Pro 2.7.2 machine.  Thx!