ArcGIS Pro 2.6.2 hanging when saving project and when performing other actions

404
8
11-03-2020 07:27 AM
BarbaraSchneider2
Occasional Contributor

I have just migrated from ArcGIS Pro 2.5 to ArcGIS Pro 2.6.2. The program freezes when I try to:

- save the project

- add a map frame to the layout

- add a new map to the project

- and more

I have checked the following post:

ArcGIS Pro Projects Hanging 

I reinstalled ArcGIS Pro and ran the System File Checker, but this didn't help.

I have also checked the following post:

ArcGIS Pro freezes when I add a map, or open a project that has a map already 

I cleared the display cache and this didn't help either. I then ran the diagnostic tool ArcMon. It indicates that the system freezes at ArcGIS.Desktop.Mapping.MappingModule.GetMapsDisplayUnits when the project is saved.

Any help is appreciated!

Reply
0 Kudos
8 Replies
DanPatterson
MVP Frequent Contributor

perhaps more important... does it do this with just one project? or all projects?


... sort of retired...
Reply
0 Kudos
BarbaraSchneider2
Occasional Contributor

This happens with every project. For example, I just created a new project, added a empty map (without basemap) and added a new folder connection. Then I tried to save ---> ArcGIS Pro freezes.

Reply
0 Kudos
DanPatterson
MVP Frequent Contributor

You will probably need to call tech support if you have done all the things in your original post.  You must have something floating around that wasn't cleaned up before you did a reinstall (eg registry entries, other applications tied to Pro etc)


... sort of retired...
BarbaraSchneider2
Occasional Contributor

Hello Dan,

thanks for your reply. Your answer inspired me to log on as administrator to my computer and try to work in ArcGIS Pro. It worked! I then compared the following folders of the administrator and of my account and cleaned up everything that was not there in the administrator folders:

C:\Users\schneidb\Documents\ArcGIS
C:\Users\schneidb\AppData\Local\ESRI\ArcGISPro
C:\Users\schneidb\AppData\Roaming\ESRI

Now, when I log in to my computer with my account, ArcGIS Pro works again!

Reply
0 Kudos
MichaelVolz
Esteemed Contributor

Can you please elaborate on what extraneous files you deleted in your profile that allowed Pro to work much better?

Reply
0 Kudos
DanPatterson
MVP Frequent Contributor

Glad it worked out! Having 2 profiles on the same machine is an issue I haven't personally encountered.


... sort of retired...
Reply
0 Kudos
BarbaraSchneider2
Occasional Contributor

I think what made the difference was deleting the following folder:

C:\Users\schneidb\AppData\Roaming\ESRI\ArcGISPro.exe_StrongName_yhpsrysqpn4fvmb0spwbakt5o5e50din

It contains the file "user.config" for every former version of ArcGIS Pro.

MichaelVolz
Esteemed Contributor

Thank you.  This will help with potential future trouble-shooting issues.

Reply
0 Kudos