ArcGIS Pro 2.5 Fails to Overwrite Web Layer - Staging Failed

2991
33
02-10-2020 01:10 PM
WalidAlmasri1
New Contributor III

I have recently upgraded my ArcGIS Pro to 2.5, and it seems now that I am unable to overwrite layers I have published (we update publicly available data) only getting an area that staging failed.  The log says ErrorMessage: ERROR 999999: Something unexpected caused the tool to fail.  Is this something anyone else is experiencing?  I was able to successfully overwrite layers on a co-workers PC who is still on 2.4.

Thanks!

Tags (3)
33 Replies
WalidAlmasri1
New Contributor III

I do, there are some users here who have it, I have not got 10 yet.  I will have to get together with them, update their box and see if it goes through.

0 Kudos
ThomasColson
MVP Frequent Contributor

Are you able to get the person in your organization that does have right to call to open a case for you? This would be the person that administers your license, etc....

WalidAlmasri1
New Contributor III

Yes, our manager here can open a ticket, but generally, we try to solve our issues.  We have only started using Pro to update our web layers for ArcGIS Data Hub.  On Friday, I will work on another users machine to get pro on their 10 box updated to 2.5.  If it works, I will say it is a windows 7 issue, if not, I will open a ticket.

Walid

KAnderson
New Contributor II

I'm having the same issue. I've had the error in the past, but it was accompanied by other database connection issues. That time is was fixed by updating the ODBC Driver, but that doesn't seem to be the case now.

0 Kudos
WalidAlmasri1
New Contributor III

What version of Windows are you on?

KAnderson
New Contributor II

Windows 10 Pro for Workstations.

0 Kudos
KAnderson
New Contributor II

My colleague is having the same issue.

It turns out that I can publish from file geodatabase (as opposed to SDE). And it only occurs when we're copying data (as opposed to referencing SDE).

0 Kudos
KAnderson
New Contributor II

With consultation to ESRI, it turns out there was something off with existing our server database. Not resolved, so we're sticking to v2.4 until they can figure out a fix or we hear we need to re-create the database.

0 Kudos
MalcolmMeyer2
Occasional Contributor II

Failure with no error code and corrupts data on AGOL (one hour before a presentation on how we are going to start using AGOL for field inspections). 

"Publishing tool execution failed"

ArcGIS Pro 2.4.2

0 Kudos
MalcolmMeyer2
Occasional Contributor II

I foolishly attempted to add a layer to my service, no knowing that the feature service #s are based on layer order, which of course changed when I added a layer. Thus the feature services were not corrupted, they were pointing to the wrong layer. This does not really answer why the service upload failed, but now I know something I didnt before.

0 Kudos