ArcGIS Pro 2.4 cannot export to any format

1458
13
Jump to solution
07-30-2019 12:22 PM
AlanStewart
Occasional Contributor

I've newly installed ArcGIS Pro 2.4 and created a bunch of layouts from existing MXDs for testing purposes. So far the product is useless to me as the final result of my workflows is always to generate a PDF and Pro has yet to succeed at this. I am using Share -> Layout Export. The output I am getting is a file where every byte in the file is zero. It does the same thing for TIFF and JPEG exports. I'm only trying to export letter-size layouts at 100 dpi. I have 16GB RAM and 50GB free disk space. I'm running Windows 7 Ultimate. Pro is not reporting an errors.

Another clue is that when I make a second attempt to export to the same file as an earlier export Pro often complains that it cannot write to the file. However, I have no difficulty deleting the file from the Windows shell, so there does not seem to be another process blocking the file.

13 Replies
AlanStewart
Occasional Contributor

BTW, to be clear, Pro has no issues that I've observed with saving or reading projects to/from the shared drive, only performing exports to it.

0 Kudos
JaimysArnott
New Contributor

I recently updated my copy of ArcGIS Pro and I can no longer export maps to PDF either. On export the files won’t open and show only kb worth of data.

  • Running as Administrator has no effect.
  • I've tried saving to a different section of my drive – still no luck. Removing spaces from the file/folder names has no effect.
  • It’s not a space issue.

Any assistance with this issue would be greatly appreciated.

0 Kudos
GillianElliott
Esri Contributor

Hi Jaimys, to confirm, did you update ArcGIS Pro to the latest version - 2.6? Additionally, are there any tiff files in your layout?

The reason I ask is that there is a known defect in this version: BUG-000132706 - Inserting a .tiff file into a report or layout results in incorrect behavior on export.

This bug will be fixed in Pro 2.7. Workarounds include:

  • Use PNG, BMP or JPG file format for images instead of TIFF file format.
  • Select Print from the Share tab of layout, and use Microsoft Print to PDF, and save the file.

I hope this helps!

Thanks,
Gillian

JaimysArnott
New Contributor

Hi Gillian,

Thanks for your response. I called through to Nicholas Goh at ESRI Australia and he diagnosed the issue. It was as you've said - tiffs in my map layout were affecting the export after updating to 2.6.0, where previously this had not been an issue. 

Frustrating though it is, I'm glad to have a workaround.

Warm regards,

Jaimys