Arc GIS Pro freezes when clicking 'browse' button in various places

2047
10
Jump to solution
01-20-2022 01:44 AM
XiaomingLi
New Contributor II

I'm working with ArcGIS Pro 2.8 and 2.9 well on Win10 with a license from my university.
But yesterday when I launched it, I found a weird problem, that when I click anywhere with the 'browse/folder' button (to locate some files or folders on my PC), the interface of ArcGIS Pro will freeze. But if I type a file/folder path, it works well. Pressing 'Esc' will unfreeze the interface, but if I click 'browse' button it will freeze again.

I suspect it is a problem related to my operating system. But I have no clue by now.

Here are some instances:

1. creating a new project.

2. connect to a folder.

3. export a feature class.

0 Kudos
1 Solution

Accepted Solutions
Robert_LeClair
Esri Notable Contributor

One thing I do every time there's a major "dot" release of ArcGIS Pro (2.8 to 2.9) is I completely uninstall ArcGIS Pro and any related items from my computer, then do a clean install of the latest release of ArcGIS Pro.  That seems to resolve any strangeness that the application may do.  Another thing I do is rename the ESRI folder in your c:/users/<user_profile>/appdata/local and c:/users/<user_profile>/appdata/ to ESRI_OLD.  This also helps prevent any issues that don't seem to make sense.

View solution in original post

0 Kudos
10 Replies
XiaomingLi
New Contributor II

Here is a solution, though I'm still not sure what exactly is the cause of this problem.
I've re-installed ArcGIS Pro several times before I posted the problem here. But those re-installations didn't work.

Then I found this post, following its instructions, uninstalling and cleaning all traces of ArcGIS Pro thoroughly beforehand and then reinstall, it works!!!

From that post, it seems the problem is caused by corrupted registry entry.
But I don't know how did this happen on my PC. I had no operations relating to registry. Could it be caused by a Windows Update or some other applications?

 

0 Kudos
Robert_LeClair
Esri Notable Contributor

One thing I do every time there's a major "dot" release of ArcGIS Pro (2.8 to 2.9) is I completely uninstall ArcGIS Pro and any related items from my computer, then do a clean install of the latest release of ArcGIS Pro.  That seems to resolve any strangeness that the application may do.  Another thing I do is rename the ESRI folder in your c:/users/<user_profile>/appdata/local and c:/users/<user_profile>/appdata/ to ESRI_OLD.  This also helps prevent any issues that don't seem to make sense.

0 Kudos
XiaomingLi
New Contributor II

Thank you Robert!

0 Kudos
GregGeise1
New Contributor II

I had the same issue. Any browse operation locks the program until you hit escape. I realized the browse window was opening but was hidden behind my Windows Taskbar. I moved the Taskbar to the side and moved the browse window. Maybe your reinstall reset the browse window to open in its default location.

CConnorMessler
New Contributor

This was the case for me too, after a clean uninstall and a new download the 'Browse" window was still appearing off the screen. Windows 11 doesn't allow you to change the Taskbar, but after tweaking the screen resolution it appeared in the bottom corner of my monitor. 

 

Thanks Greg!

Katherine_Rudzki
New Contributor

This is what did it for me. I tried un/reinstalling and that didn't solve anything. Changed the screen resolution and the window popped up immediately. Incredible. Thanks for the solution!

MyriamGomez
New Contributor

THANK YOU ALL OF YOU. I've been going insane for a day and a half including uninstall and reinstall over this. Moved the taskbar and there it was hiding by where the Windows Search bar would be. 

0 Kudos
ECanGIS_Team
New Contributor III
0 Kudos
LowCarbonGmbH
New Contributor

Another hint, if you using a second screen, try to unplug it. It worked for me. The folder searching window was at the very lower corner and not showing when the second screen was connected.

0 Kudos