Aerials having different projections do not aligning using Pro

164
3
04-22-2021 06:45 AM
ChetShuler
New Contributor III

I work for a city of 50k that spans 2 counties.. I use a lot of county data in my apps.. Now an issue has come back to haunt me.. It appears AGOL apps are turning the WEB MERCATOR PROJECTION. I have one county providing aerials in a STATE PLANE PROJECTION. It appears Pro will not transform the projections and I'm getting an offset in the aerial display. 

Also when I perform a geometry calculations the point or coordinates are not correct. ArcMap works perfectly.. Is there a bug preventing Pro from doing the transformations?

Tags (1)
0 Kudos
3 Replies
Robert_LeClair
Esri Frequent Contributor

When you add a new Map View, the coordinate system is WGS 1984 Web Mercator (auxillary sphere) for your map.  This is coming from the Basemap layer- typically the default basemap of your organization or ArcGIS Online.  The first operational layer you add (vector or raster) defines the coordinate system of the Map.  In my example, it's NAD 1983 Stateplane Colorado North FIPS 0501 (US Feet).  By default, ArcGIS Pro applies a geographic transformation to resolve the issue.  In ArcMap, this is the opposite - no transformation is applied.  You are notified in a warning window and it's up to you to figure out the correct transformation method.  Many customers click "Close" as they don't understand this message.  I'd suggest going into your Map Properties->Transformation and see if a transformation is applied.  If not, then best practice is the select the first one in the dropdown box between the "left" and "right" coordinate systems listed.  See my image below:

transformation.JPG

0 Kudos
ChetShuler
New Contributor III

I'm sorry I should have mention the aerial is a service provided by a consultant.. Using the Web Mercator projection.. Also the zoom setting are not  being applied in my apps.. WTMS service properties show settings of 533.182396 and 266.591198 in Pro. Add those to the custom scales in my apps and still no luck..

 

So I got two issues with the aerial service.. I can't get to transform to State Plane and the zoom setting will not apply..     

0 Kudos
ChetShuler
New Contributor III

I also tried to load the service first... Check my mapping projection to Web Mercator.. Then add my State Plane aerial.. No luck still has a shift..

0 Kudos