Refresh Domains

712
17
11-17-2019 06:05 PM
Status: Open
Labels (1)
MicheleHosking1
Occasional Contributor

I have just finished adding many domains to a new enterprise geodatabase using the Table to Domain tool.  However even after refreshing the database connection when I open the Domain view all the domains I just added do not show up.  I tried removing the database connection and adding it to the project again but with the same result. 

It appears the only way to make these domains show in the Domain view is to close ArcPro and open it again.  This seems clumsy.  It would be great if the refresh of a database connection would actually pull back all changes.  It's a pain to have to close ArcPro just to see this sort of thing.

17 Comments
MicheleHosking1

Hey there Kory,

No I didn't have any maps open that were using the domains.  I basically was just doing everything in the catalog pane and then opening the domain view by right clicking on the database connection.  No maps even in the project.  I'm working with an enterprise geodatabase rather than a file geodatabase just in case that matters. 

It's weird that it doing it slightly different for you...

KoryKramer

Thanks, Michele.  Tyler Schwartz‌ are you working in an enterprise gdb or file gdb?  Can you share whether you have layers in a map that use the domain being updated?  Thanks.

TylerSchwartz2

File geodatabase.  Yes, the featureclass within the domain file gdb is added and visible in the map (selecting it is how I am navigating to the data>domain ribbon/window).

And to respond to your comment in the other thread, per my testing just now, closing the domain window works on the first time running "table to domain" GP tool (ie: for the first domain added), but running subsequent table to domain GP tools does not reveal the subsequent domains, even after closing and re-opening the domain window. So it appears to only work on the first domain added, but thats it.

Still need to close out of Pro in order to get those subsequent domains to appear.

KoryKramer

OK, we have the issue reopened: BUG-000085913: The Table To Domain tool does not show the new domai.. 

You can go there and use the Subscribe button for updates.  Sorry for the confusion on this one - it appears that it isn't entirely straightforward.  The team is reassessing this.

Thank you!

ThomasColson

Kory Kramer‌ see my post in EAP on this topic. Seems to be related to 

BUG-000115054, BUG-000085913, BUG-000104598, BUG-000116032

HNoakes

Wondering if there has been any progress on this? Should I log a case as we have run into this problem on a project as well.

Thanks,

Heather

CathyWilson2

Just so you know, I am having the same issue in ArcGIS 2.5.1. Created new domains, opened the Domain view, they aren't there. I do have features added to a map, though they are only in the Contents, not actually on the map because there are no records in them yet. I am using a file gdb. The only way I could get them to appear was to close Pro and then open it up again, open the Domain view again and there they are.