Please make the ArcGIS Pro Ribbon more customizable.

263
5
04-13-2018 02:41 PM
Status: Open
Labels (1)
New Contributor III

*Posting here because there isn't a category for ArcGIS Pro - Sorry!*

I would like to make up some custom menu tabs for ArcGIS Pro and I'm finding it excruciatingly limiting. For example, if you create a custom tab, or edit an existing one, you can't re-order it with the other tabs, like you can with MS office products. Office, for example has move up move/down buttons on the right (see attachments). Pro does not have this functionality. Moreover, when you add a new group, make it so that you can add an options button to get back vto the options window instead of having to click on Project and get taken out of your map session.

There's a bug. If you delete the group name, you cannot get back into that group to add or remove tools. The little expandable triangle thing disappears. The only option is to delete the group and start again.

Also, can it be possible to reorder things on the quick access toolbar, so that you can group certain tools together, e.g. right-click "Move tool" or Customize quick access toolbar. Again, this functionality is available in Office products like excel, word etc.

Finally, can it be possible to add groups and tools directly to a ribbon tab, e.g. Right-click on the massive amount of wasted empty space in the Data tab and "Add New Group" > Add Tool" and "Remove Group > "Remove tool"

Thanks in advance.

5 Comments

Thank you, Carl.  There are several ideas here as part of the overall theme.

In 2.2 coming this summer, you'll see the ability to more fully customize the Quick Access Toolbar.

Sneak peek:

You've included some other good suggestions here that we'll be sure to share with the team.  

A question for you: Can you please provide more details on this?  I don't understand when you say delete the group name... It will be important for us to understand if we're to fix it!

There's a bug. If you delete the group name, you cannot get back into that group to add or remove tools. The little expandable triangle thing disappears. The only option is to delete the group and start again.

Thank you!

Oh, and don't forget to up vote your own idea ctownsend_2017‌!  Please provide more details about you're calling a bug so that we can look into it.

Cheers

OK, This does seem to be a bug...I tried to replicate it to screengrab it and show you, only it's not doing it! Maybe you can try and replicate it. Basically, I wanted to rename the tab, from Main Tab to something else, but was wondering what to call it; I'd already deleted the name and thought "Oh I'll just come back to it later" so I clicked OK and left it. When I went back to it later, the tab listing was there, but all the subgroups under it didn't have the the expand triangles so i couldn't add new tools to the groups... I had to can it all and start again with a new tab from scratch. That's how I came across it. Now if I delete the name, it changes to 'Unknown'.

Anyway. As you can see those reorder buttons are missing and really needed! If you customise a tab it makes it much nicer to move them afterwards, especially if you add new tools that you realise you need. Currently you have to have your tool ordering plan in advance and insert them in the order you want. Nice that we're getting the ability to reorder the quick access toolbar - but is it possible to make it even better by right-click > move/reorder directly on it? It seems long winded having to go into options to do it.

Thanks!

Thanks, Carl.  

OK, it appears that the behavior you're describing happens only on the first "rename".  That is, it has to be the first time I've opened the Options > Customize the Ribbon.  If I delete the tab's name and click OK, it appears that nothing happens.  That is, what I SEE is that it has retained the name.  When I close the Options dialog and come back to it though, I now see that the tab is called Unknown.  That would be the bug.  I've logged the following:

[BUG-000113233: Deleting the name of a Tab in Options > Customize the Ribbon does not provide the user with feedback until the Options dialog is closed and re-opened.]

However, I don't see the lack of expanders that you describe.

Thanks again for the feedback. The development team has the bug that has been logged and we also have this idea and comments that will feed into continued design consideration for the customize experience.

Thanks! What I found was it wasn't even 'Unknown' It was completely blank, and the expanders under it were gone. Too bad I didn't screengrab it.