Make ArcGIS Pro honor system's default web browser when clicking links

1059
3
07-10-2017 09:26 AM
Status: Open
Occasional Contributor III

Scenario:

I have a web link in a popup that looks something like this: http://my-website.com/{OBJECTID} This link is to an internal application which opens up a details page on the record.

When clicking on a popup link in arcgis pro, the resulting web link is opened in Internet Explorer. This is not what a user would expect if the default browser is set to Google Chrome or Firefox.

As far as I know this isn't a very complicated procedure, opening a link in an addin requires something like

System.Diagnostics.Process.Start("http://my-url.com");

Benefits:

  • Some applications do not work in versions of internet explorer and it would be very useful to allow pro to open other web browsers.
  • If a user is used to using chrome, and is signed in to a web service, they won't have to sign in again when clicking links to the web service in pro

Related:

How do I change ArcGIS Pro's default browser in the pop-up from IE to Chrome? 

3 Comments

I second this. We just had an Esri Tech Support Case where the issue was that I was linking to a pdf and I had Adobe Acrobat and Adobe Reader installed on the same machine and because it defaults to Acrobat over reader as the default pdf handler, it was taking 45 seconds to load a that was hyperlinked. This issue was only replicated in an IE environment and Chrome and FireFox had no issue opening the same URL path.

For us at my city, we would need either a change to allow the acceptance of the default web browser  or for the integration between IE and Acrobat to be fixed in order for us to consider adobpting ArcGIS Pro.

Our direct workflow is that we have hyperlinks currently being consumed through ArcMap, which have no issue, that our front counter staff rely on daily (recorded subdivision plans, FEMA LOMA documents, etc.). This path in ArcMap is currently a direct path <server name>\Engineering\FEMA\<case number>.pdf and it opens fine without going through a web browser however this link style isn't possible in ArcGIS Pro and it must be go through a web server in order to pull open the link. In my eyes there are many changes that should be considered with the hyperlink process in ArcGIS Pro.

Has anyone here tried this recently?  It works in Pro 2.3 and in a daily build of Pro 2.4...

I am currently working in Pro 2.3.3 and hyperlinks currently randomly open in Internet Explorer, even though Chrome is my default and 95% of the time the links open in it.  Not sure if this is related.